Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: 9500 Screen Tearing

01 Dec 2009   #1

Windows 7 Ultimate
 
 
9500 Screen Tearing

Hey there.

I recently installed a Nvidia 9500 graphics card on my computer. But when i installed the latest drivers I get quite noticeable screen tearing and when i open up world of warcraft the screen flashes black like every 6 seconds. Please Help.

-Karius-

My System SpecsSystem Spec
.

01 Dec 2009   #2

Windows 7 Pro & Vista Home Premium
 
 

Is that the only problem you have is the Warcraft game?
My System SpecsSystem Spec
01 Dec 2009   #3

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by reghakr View Post
Is that the only problem you have is the Warcraft game?
Nope its also my screen in general is when the screen tearing happens but it only flashes black with warcraft.
My System SpecsSystem Spec
.


01 Dec 2009   #4

Windows 7 Pro & Vista Home Premium
 
 

Did you get the driver directly from Nvidia?
My System SpecsSystem Spec
01 Dec 2009   #5

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by reghakr View Post
Did you get the driver directly from Nvidia?
Yep
My System SpecsSystem Spec
01 Dec 2009   #6

Windows 7 ultimate 64 bit / XP Home sp3
 
 

If you would update your system specs in your user CP ( top of page, then edit system specs) this would help to understand more about your system. Also what card are you upgrading from? As it seems that this type of issue happens when upgrading form a card that used old legacy drivers. I would recommend using a driver cleaner app like driver sweeper, or driver cleaner to clean out all remnants of old drivers then try to reinstall the new ones and see if the issue persists. Guru3D - Driver Sweeper (Setup) download from Guru3D.com
My System SpecsSystem Spec
01 Dec 2009   #7

Windows 7 Ultimate
 
 

Hey i've updated my specs as much as i could in my cp. Plus i upgraded to 9500GT to 7100gs btw.
My System SpecsSystem Spec
01 Dec 2009   #8

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Thanks. Well it would seem that the driver from Nvidia is the same for both cards so that would eliminate the legacy theory. I don't see your monitor listed. If you can please include it. I will do some more research and get back to you. Fabe
My System SpecsSystem Spec
01 Dec 2009   #9

Windows 7 Ultimate
 
 

Hey but in device manager it just says Generic PnP Monitor...
My System SpecsSystem Spec
01 Dec 2009   #10

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Well then if you can find the manufacturer and model # I would go to their site and download and install my monitor driver. Also is this occurring as soon as you turn on your system? As this can also be a heat related problem if not always present. Also if you'll scroll down this page you'll see other threads on this issue. The second one has a lot of information that might help you as well. Fabe
My System SpecsSystem Spec
Reply

 9500 Screen Tearing





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:00 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33