Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Help. Geforce 9600 GT Win7 = terrible performance.

11 Dec 2009   #1
abc

7 64
 
 
Help. Geforce 9600 GT Win7 = terrible performance.

Hello!!!!!!!!!

My system is as follows,

Windows 7 64bit
Gigabyte M720-US3
Phenom 2 945
2gb corsair XMS2 DDR2 800mhz
Display driver 195.62

I'm getting really bad graphics performance. I lost like 10 FPS on RE5 benchmark versus windows XP 32bit. On Left 4 dead 2 my average FPS is around 35-45, and even lower if I turn shader quality up to maximum (which the game recommends)

On my old system (AMD 3800 X2 Win XP) I never got any slow down on L4D 1 and there isn't much difference between the 2 games graphically.

I ran SiSoft Sandra GPU benchmarks and my GT 9600 scored quite a bit lower then the reference cards.

My memory and CPU clock are both at stock.

Is this a driver problem? What can I do to improve things, please?

Add a reply


My System SpecsSystem Spec
.
11 Dec 2009   #2
Legacy

Windows 7
 
 

Install the latest chipset/motherboard drivers and also video card driver from NVIDIA's website.
My System SpecsSystem Spec
11 Dec 2009   #3
abc

7 64
 
 

Quote   Quote: Originally Posted by Legacy View Post
Install the latest chipset/motherboard drivers and also video card driver from NVIDIA's website.
Tried. in my OP it shows I have the latest Nvidia drivers anyway.

Anyone, please?
My System SpecsSystem Spec
.

11 Dec 2009   #4
Legacy

Windows 7
 
 

Nobody could give you better advice than what I already gave.

Maybe you have too much stuff starting with Windows and/or AVG installed.

In either case, it should be apparent now what to do to fix it.

Install this too: http://downloads.guru3d.com/nForce-15.51-WHQL-Windows-7-and-Vista-64-bit-download-2402.html

Or if that doesn't work for your board, install the chipset and all other latest drivers from here:

http://www.gigabyte.com.tw/Support/M...4bit#anchor_os
My System SpecsSystem Spec
11 Dec 2009   #5
abc

7 64
 
 

I tried the Gigabyte drivers. It's very strange beccause the installer will only give me the option of installing the Nvidia away mode driver. There isn't much evidence of nvidia in devicemanager / hardware. I'm actually not certain if the drivers are properly installed but I wonder if there is an efficient way to check?
My System SpecsSystem Spec
11 Dec 2009   #6
Legacy

Windows 7
 
 

Yes. You can look at the dates of the drivers in C:\Windows\System32

You can also use the device manager to install for each driver, but you have to know which ones first:

Right click. Update driver software. Browse my computer. Let me pick. Have disk. Browse. Find the extracted .inf from the installer. Double click it. Hit ok. Hit next.

All NVIDIA drivers start with NV like nvstor.sys etc...
My System SpecsSystem Spec
11 Dec 2009   #7
abc

7 64
 
 

I've attached a S/S of my device manager. It's very hard to know which driver goes where. All the drivers are Microsofts own. I know this just can't be quite right. Auto-update search just says the latest and greatest driver is installed. Sigh.

I'm supprised Gigabyte are so lazy with their driver installation software. I know I won't be buying from then again!!!


Attached Images
 
My System SpecsSystem Spec
11 Dec 2009   #8
TGSoldier

 
 

Was this an upgrade or clean install?
My System SpecsSystem Spec
11 Dec 2009   #9
Legacy

Windows 7
 
 

You should be able to install the drivers just by running the installer from the link I gave, for "Chipset/Lan" drivers, to completion. It will install anything that needs an update.
My System SpecsSystem Spec
11 Dec 2009   #10
abc

7 64
 
 

No, I tried the gigabyte link (which i've tried in the past) only wants to install the away mode driver, like I could care less about that one lol. The driver from guru 3d said no compatible hardware was detected for the drivers on the system. Facepalm.

Yes this is a clean install, format > windows 7.
My System SpecsSystem Spec
Reply

 Help. Geforce 9600 GT Win7 = terrible performance.




Thread Tools




Similar help and support threads
Thread Forum
[HELP] Installing my GeForce 9600 GT
I just bought an MSI motherboard with an onboard ATI graphics. Everything has been installed from my MSI Driver CD/DVD. Im about to install my GeForce 9600 GT graphic card but i've read few info about some problems about this in forums and im really worried about what will happen so I posted...
Graphic Cards
Nvidia Geforce 9600 GT
Hello everyone, I recently added the Nvidia Geforce 9600 GT to my computer, it has 512mb of ram, the install went perfect, but whenever i play a game, in my case, world of warcraft. the monitor will turn black as if it wasnt picking up a display, after about 15 minutes into my game, sometimes...
Graphic Cards
GEForce 9600 GT
[hi all my problem with GeFroce 9600 GT when i have windows xp GeFroce 9600 GT was work in games 100% but now when i put windows 7 its does'not :( y !! any body please solved my problem
Graphic Cards
GeForce 9600 GT performance drop on Windows 7 Ultimate
I have an nVIDIA GeForce 9600 GT and recently installed Windows 7 Ultimate 64 bit (upgraded from Windows Vista Ultimate 64 bit) on my desktop PC. I expected an increase in graphics performance - which was the case with my laptop (which has an nVIDIA Quadro FX 770M) - but instead the Windows...
Graphic Cards
Geforce 9600 GT Overclocked.
Ok. so i just replaced a failing 8500 with a 9600GT(Pre Overclocked.) Out of curiosity i re ran the windows assessment tool. Aero graphics went from 5.1 to 7.9 = :D Gaming Graphics went from 4.3 to 2.0 = :rolleyes: What the hell gives with that? Im running windows 7 build 7022 by the way.
Graphic Cards
GeForce 9600 GS Missing
I installed the RC 64 bit with no problems onto my ASUS M50Vm with 4GB DDR2, 2.53 dual core, 320 GB HD, nVidia GeForce 9600 GS. However, it doesn't seem to think my graphics card exists. I tried to update drivers, but it won't let you update drivers for a device you don't have. I went into device...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:26.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App