Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: my HD5970 experience

16 Dec 2009   #1

my HD5970 experience

ok...... so here's my HD 5970 experience.

my HD5970 experience-120809092918.jpg
my HD5970 experience-120809093008.jpg

upon receiving the card i was as happy as a pig in poop , packaging was great, card was sealed..(for some reason they love to pull these cards out of the boxes at the warehouses..??)

its an absolute MONSTER, i knew it was big but it makes my GTX260 look like an add in PCI, the card itself weighs nearly 2 kilos... its a thing of beauty though ppl

so i clean my rig of Nvidia traces & power down, remove the 260 clear a space for the 5970, reposition the needed wires & boot up....... no picture..??, rig posts but no signal.

so i begin reseating the massive thing, 3 times i moved it & switched cables, on the 4th time (not sure why) it powered up..

so.... i load into ''safe mode'' (note at this point the rig did not recognize the card, all it listed was ''standard VGA adapter'' i know there's no drivers but a GPU will be recognized upon first boot & will await driver), so i run ''driver sweeper'' again to be sure & attempt to load up the BETA driver i had got off the net a few days before the card arrived,

fire up the launcher..... ''there are no supported devices''

ok so its fair to assume by this point im cursing ATI, tried it a few more times ...same deal, so i decide to try the drivers that came with the card,

fire up the disc.....''there are no supported devices''

right now ive lost the plot... i tried everything i could think of inside ''safe mode'' but no joy.... so i thought another reseat was my only option (i knew the reason the driver wouldn't install was b/c the rig had not generically detected the card).... so i power down, but i hit restart rather than shutdown....

so instead of shutting it off manually i let it run through to windows to see what would occur.

upon loading windows the OS recognized the card & finally i was up & running (without reseating again), so the driver completes & i reboot......

firstly i had fan control straight out of the box so there was no need for a flash....

when i get back to windows im met with heavy artifacting over the 2nd monitor , at first i thought it was a faulty core as the system would also lock randomly & force a reboot, but the more time i played around with it the more i realized the H/W was fine.... gaming performance was EXCELLENT!! & i had no artifacting while the card was loaded out..

after spending a few days scouring the net it turns out these ''glitches'' were a common issue with the 5 series cards.

dual monitors & CFX were a known problem nearly ALL 5 series users were experiencing, the 2D clock settings on these cards are 157/300 (as apposed to 850/1200 & 735/1010), these setting are too low on dual monitor setups & it causes instant corruption while idle... (later found out from sapphire that it needs to be 400mhz min for dual screens)

so after days of crashes, lockups & general glitches the 9.12 cat driver was released.....this has solved the 2D issues & boosted performance GREATLY!!, but..... ive lost the use of CCC, so i cant load my color settings.... typical

now then..... performance.

i can now confirm that there is a HUGE bottleneck with this card on a PCIE 1.1 slot (i kinda knew there would be), it hasn't been an issue with previous cards but the 5970 completely saturates this connection, & then some.

its not a power issue, even though my connections only deliver a rated 300w (1x 75w PCIE)(1x 150w 8pin)(1x 75w 6pin), the card will draw ALL extra power required through the plugs, its a bandwidth issue..... not only does a GEN 2 PCIE slot deliver 150w it also doubles data bandwidth from 250mbps per lane to 500mbps per lane, so im being choked quite badly..

im planning ''i9'' in a few years so im just gonna grab a cheap X48 in the new year to fully open her up while using existing H/W until the big Gulftown push..


this card clocks like a charm , & holds stable clocks with very small voltage boosts......

i flew past CFX 5870 clocks, i made it all the way up here (see image) furmark stable, but as said above the bottleneck is choking data transfer even though the card is firing on all cylinders.

my HD5970 experience-59.png
my HD5970 experience-gpuz-ati.png

here's my benches........

vantage ...... @ 5870 clocks, (pay close attention to the GPU score )

my HD5970 experience-vantage-4.png


my HD5970 experience-much.png


my HD5970 experience-fur-temp.png

here's an image after running the furmark burn test, it ran for 15 mins..... look at the temps, EXCELLENT.

also i cant sing my praises enough for MSI afterburner, its an amazing bit of kit, it allows you to set a ''power curve'' for your GPU fan, never again will i have to worry about it before gaming.

i'd like to tell you im pissed off with all the crap ive undergone this past week, but its just an AMAZING card, that chomps through everything i throw at it, i mean GTA4 is ASTOUNDINGLY FPS never drops below 70... EVER!!, now anyone who plays this game will know that in itself is an amazing result considering how poorly coded it is.

so ...... im happy now, but the change to ATI has been a rocky road.

but its Christmas & life is good...

My System SpecsSystem Spec
16 Dec 2009   #2

Windows 7 Ultimate x64

i'm officially jealous...
My System SpecsSystem Spec
16 Dec 2009   #3


Quote   Quote: Originally Posted by mpcrsc562 View Post

i'm officially jealous...
lol....... im just loving the 0 lag in ANY game, & its early days in terms of DX11s capabilities.

once i pick up the X48 board im gonna grab a 5770 too (TriFire baby )
My System SpecsSystem Spec

16 Dec 2009   #4

Vista Ult64, Win7600

Hi,thanks for making me feel bad, is there a new driver out 9.12?
My System SpecsSystem Spec
16 Dec 2009   #5

Windows 10 Pro

Nice review Skunksmash

Thanks, and as they say in ATI land "Welcome to team red"

I'm getting ready to build an i7 system in Feb and may pick up one of these cards if the price is right and the issues get ironed out.
My System SpecsSystem Spec
16 Dec 2009   #6


Quote   Quote: Originally Posted by jfar View Post
Hi,thanks for making me feel bad, is there a new driver out 9.12?
its not officially out on AMDs site, but it is the 9.12 release....

its up in the ATI drivers thread
My System SpecsSystem Spec
16 Dec 2009   #7
PooMan UK

Windows 7 Ultimate 64bit

Man that card is like the dogs doo dars, if swearing was allowed on these forums my post would look slightly different, but nice one pal.

I've been an nvidia freek for most of my life but have recently just upgraded from 2 x BFG 9800 GTX to an ATI 5850 and I'm well chuffed ... big improvement but I'd like to switch to crossfire and try 2 x ATI cards to see how that performs. Just gotta get the wife to stand under the Red lampost for a few months to generate enough pennies to get a crossfire board and second GPU

But please let us know if you do any more testing and show us the results. I for one am keen to see how it goes
My System SpecsSystem Spec
16 Dec 2009   #8


cheers lads.......

but my results dont do this card justice, here's what this card scores with a PCIE 2.0 board (check GPU scores)

its a monster!!
My System SpecsSystem Spec
16 Dec 2009   #9


9.12 is supposed to come out today (Australian time zone) and btw - this card can do aero
My System SpecsSystem Spec
16 Dec 2009   #10

Windows 10 Pro

Quote   Quote: Originally Posted by MyWin7 View Post
this card can do aero
Not sure what you mean, but of course it can. It's ATI's flagship card

And for the money, it better!
My System SpecsSystem Spec

 my HD5970 experience

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Atikmpag.sys BSOD on ATI HD5970
Hi guys, I'm having a major problem with the "atikmpag.sys" BSOD error whenever I try to play video games (and the occasional random crash too). Oddly enough, it never happens while rendering in Cinema 4D, so I've pretty much ruled out it having something to do with how intense the GPU usage is....
Graphic Cards
Anyone Else Experience...
Hello new guy here:D I couldn't really find a suitable place to put this so iv'e placed it here sorry if it's in the wrong section. EDIT: Windows 7 Home Premium x64 and before i updated i had a custom theme which meant i had to patch the system files. i never replaced the patched ones to the...
General Discussion
My PC experience :(
Hi, This is going to be a big story, nay rant but if you want to read it go ahead. I made my own custom PC in late 06' basically being my setup now. It started off working well but now I think of it have had graphics problems and problems in general every since. After upgrading the video...
General Discussion
hd5970 hangs at start up
hd5970 hangs at start up sometimes then you turn pc off then on then press key too start windows normally then works fine. then when you leave off for few hours you have too do the same again.
General Discussion
HD5970 to launch on Nov 18th
ok peeps, introducing the FASTEST dual GPU GFX card on the planet, measuring in at a MASSIVE, 12.5''.... HD5970 (HD5870x2) :D
Graphic Cards
What was your first Experience with a PC/OS ???
Well as for me my first machine i ever touched was the Mac OS (i believe it was 6.0...) that was in elementary (1996... yes we were behind the times, this school didnt have much money...) then in 98 to upgraded to Mac 7 and finally to 8..... That was the last i saw or heard of the Mac until OSX...
Chillout Room

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:38.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App