Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win 7 not detecting hardware

22 Dec 2009   #1
Andrew303

Windows 7 Home Premium
 
 
Win 7 not detecting hardware

Hey guys,
Recently i upgraded win XP to win 7 with a format and fresh install. Though after the install, Win 7 did not pick up my onboard sound card or my usb modem. I have the drivers for them but how can i install them if Win 7 wont pick them up? they dont appear in the device manager at all. Win XP had no problem at all with this. Is it possible that they hardware is to old to be recognised by windows 7? i dont have the XP software to switch back so hopefully ill be able to fix this with assistance.


My System SpecsSystem Spec
.
22 Dec 2009   #2
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Quote   Quote: Originally Posted by Andrew303 View Post
Hey guys,
Recently i upgraded win XP to win 7 with a format and fresh install. Though after the install, Win 7 did not pick up my onboard sound card or my usb modem. I have the drivers for them but how can i install them if Win 7 wont pick them up? they dont appear in the device manager at all. Win XP had no problem at all with this. Is it possible that they hardware is to old to be recognised by windows 7? i dont have the XP software to switch back so hopefully ill be able to fix this with assistance.

Before you did the upgrade did you use the micorosoft upgrade advisor to detect any incompatablities?
My System SpecsSystem Spec
22 Dec 2009   #3
Andrew303

Windows 7 Home Premium
 
 

Unfortunately i didnt. I just discoverd that windows 7 does not support my USB modem so i have to try ethernet. Device manager picks up a ethernet controller but its a old card) (Asante LC82c115-based 10/100 ethernet adapter and im guessing windows 7 wont support it either. The onboard sound card isnt displaying so im guessing it isnt suported. i guess ill have to purchase 2 new cards?
My System SpecsSystem Spec
.

22 Dec 2009   #4
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Hi Andrew.

For the onboard sound you can get the driver directly from Realtek, which in your case is the AC'97 based one and can be found here,

Realtek

As fa as the ethernet driver goes your motherboard does not have any onboard ethernet, you have a NIC/ethernet card in it (checked the user manual for your motherboard). As far as the card that is in it you have a few options,

1. Try hunting high and low and see if you can find the card manufacturer and/or try and find a Vista/Win 7 compatible driver

2. Look into getting a newer modem that uses USB and has Windows 7 support

3. Toss the old ethernet card that is currently in there and get a new one that has Windows 7 support

Personally I would go with number three as it will be the cheapest and easiest method, and can be had for less than $10 (assuming you're in the US),

Newegg.com - Rosewill RC-402 10/100Mbps PCI LAN Card 1 x RJ-45 - Also Supports WINDOWS VISTA READY - Network Interface Cards
My System SpecsSystem Spec
22 Dec 2009   #5
Andrew303

Windows 7 Home Premium
 
 

Hey mate,
After a long night of searching for the ethernet drivers i was unsucessful as they dont support vista/7 so yeh ill go with option 3 and just purchase a new card that is supported, but as for the sound i have had help with it before in these forums and had no luck. It seems that after installing the correct drivers that are compatible, it does not read that i have any sort of sound hardware at all. Its as if the onboard has stoppped functioning as i have exhausted every possible option. I think ill just purchase a new sound card as well that will be compatible. Thanks alot for your help.

Andrew.
My System SpecsSystem Spec
22 Dec 2009   #6
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Just saw your other thread about the audio. Is there anything in Device Manager showing as "unknown"? Main one to look for would be "multimedia controller". If it is listed that should be the onboard sound. You can also try and install the driver manually (same one I linked too previously),

Device Manager - Install Driver - Vista Forums

That is for Vista but he same applies to Windows 7.

I think you will find that the biggest problem is the chipset on your motherboard, Intel 845E which was declared EOL (end of life) quite a while ago by Intel. As a result there are no drivers for the motherboard (which are responsible for telling the OS what to go and do with itself in regards to any hardware installed), and Windows will only install whatever it has built in; probably just enough for most things to work. If that is what it is it would also be why you can't get the sound to install.

P.S. From your other thread you mention the gameport, and yes those are no longer supported under Windows 7 (or Vista for that matter). If it is something that you want/need to use, then XP is about your only option. If you don't need/use it, look in the bios and see if there is an option to disable it.
My System SpecsSystem Spec
Reply

 Win 7 not detecting hardware




Thread Tools




Similar help and support threads
Thread Forum
Computer not detecting network hardware
Hello, I recently installed Windows 7 Ultimate x64 onto a laptop which once has had working internet. Since the installation has been completed, I no longer have access to internet. Wireless or wired. In the bottom right of the screen it has the network icon with a red X through it. When I try...
Network & Sharing
Lenovo Wifi Hardware not detecting after Win7 Formatting
hey guys, please help yesterday night i formatted my friend's lenovo laptop with Win7 Ultimate, All went perfect but when the desktop appear, i looked upon the network icon on the right bottom of the taskbar a cross sign appeared on it. Solutions - 1. i tried updating the drivers through device...
Hardware & Devices
Windows 7 - Not detecting any networking hardware
I'm looking for some assistance to the above problem I'm having with my desktop. I am unable to connect to the net through this PC, however, the net connection is working fine as I am currently connected wirelessly via my laptop. The icon on the tool bar has a red cross indicating that I'm not...
Network & Sharing
Not detecting second screen
I received my new pc today and after I set it up I tried to plug in my second monitor but it is not detecting it. my graphics card is a radeon HD 6950 2gb http://www.sapphiretech.com/presentation/product/?cid=1&gid=3&sgid=1041&pid=1235&psn=&lid=1&leg=0 can anyone help?
Graphic Cards
WMP Not detecting my media.
Normally this wouldn't be a problem, but I cannot stream media to my PS3 without my media being in the WMP library. My libraries are configured to point to the proper places, and the libraries show up in WMP as added when I try to add them. Hopefully this helps. I tried rebuilding the database,...
Music, Pictures & Video
W7 64 bit only detecting 3GB out of 4GB
Hey there, I recently installed a 4GB DDR2 800Mhz and under Control Panel\All Control Panel Items\System i can see that installed memory 4.0GB (2.94 usable) so i have 1 GB of ram missing ! :cry: anyone?
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App