Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Can't install a new graphics card.

29 Dec 2009   #1

Windows 7 32-Bit
 
 
Can't install a new graphics card.

Hi,

I've just bought a PNY Geforce 6200 512Mb DDR2 AGP8X graphics card and have been trying for five hours to get it installed on my system.

My motherboard is a Gigabyte GA-7DXE (which is quite old and supports AGP4X but I've heard it can support AGP8X)

I reach the 'Starting Windows' screen before it stops and does nothing.

There is no trouble in me using a standard VGA adapter installed in the AGP slot. I tried uninstalling the driver for it and restarting the computer with the new card in but the startup process only goes so far before stopping at the 'Starting Windows' screen.

Every now and again the HDD light on the front of my case will flicker and I will hear the HDD spinning (and having a think about loading or something!) but then it ceases.

I've been online and downloaded the latest drivers for this graphics card but Windows 7 won't let me install them because I need to have the card plugged into the motherboard in order for it to let the installation proceed. On the installer I get the message,

"The nvidia setup program could not locate and drivers that are compatible with your current hardware."

[*Of course I am viewing this message using the standard vga adapter because I can't use the new graphics card because it won't get past the 'Starting Windows' stage!]

When I go into safe mode the loading process goes up to amdagp.sys which I think is the last bit before it should take me to the 'Welcome' screen.

I've downloaded the latest chipset for my mobo from Gigabyte's website (although the release date was back in 2002!

*Breaking news, Windows Update has just offered me an update for Geforce 6200! However the installation failed. Here's a link to the screenshot:

http://www.************/file/183891589/cfa2...ate_failed.html

I think it's still to do with not having the card plugged into the mobo. I wonder if I put in the new graphics card and set Windows Update to run in ten minutes time, would it apply the update because the card would be present?

Thoughts?
Thanks,

nivekinski

My System SpecsSystem Spec
.

29 Dec 2009   #2

Windows 7 Professional x64
 
 

Hello, Welcome!

The dilemma is that Windows cannot boot when the card is attached, but AGP is not hot-pluggable.

Do you happen to have 2 video cards?

This problem is beyond me, but you never know.

~Jonathan
My System SpecsSystem Spec
29 Dec 2009   #3

Windows 7 32-Bit
 
 

I do have two cards. But they are both AGP.

One is a standard VGA adapter and the other is the card that I wish to install. So I can view and run Windows off the standard card, but I can't plug in the new card to install the necessary drivers for it!

It's quite frustrating. And now Windows Update isn't showing me the Geforce 6200 update any more! (It failed before).

Any ideas?
My System SpecsSystem Spec
.


29 Dec 2009   #4

Windows 7 Professional x64
 
 

Ditch the idea of using Windows Update. Try downloading the drivers for your card directly from the manufacturer. That is the most reliable way.
My System SpecsSystem Spec
29 Dec 2009   #5

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Can you borrow an old PCI VGA video card & plug in along side the AGP to see if you can boot using the PCI video display in the Bios ?


" Doc "
My System SpecsSystem Spec
29 Dec 2009   #6

Windows 7 32-Bit
 
 

I could go to the local PC store and 'borrow' a PCI graphics card?

Also, I've downloaded the latest updates for the card from nvidia's website but I can't install them because the card needs to be plugged in for the installer to run! (which is why I should perhaps try using a PCI card!)

I guess the PCI way has got a good chance. I'll look into it...

Thanks.
My System SpecsSystem Spec
29 Dec 2009   #7

Windows 7 x64
 
 

Here's your motherboard specs GA-7DXE - GIGABYTE - Product - Motherboard - Specification

Expansion Slots
  1. 1 x AGP 4X
  2. 5 x PCI slots support 33MHz and PCI 2.2 compliant
You can use a AGP 4x card in a AGP 8X slot but not the other way around. I don't think your motherboard is compatible with AGP 8X.
My System SpecsSystem Spec
29 Dec 2009   #8

Windows 7 32-Bit
 
 

Dang! Really?

If I use the AGP8X in a AGP4X slot does it not just run at 'half speed' (4X)?

I guess I'll need to look around for an older model or a PCI alternative (not PCI-E however! lol)

Man, this computer is ancient!
My System SpecsSystem Spec
Reply

 Can't install a new graphics card.





Thread Tools



Similar help and support threads for2: Can't install a new graphics card.
Thread Forum
BSOD's before and after new graphics card install and new cpu install BSOD Help and Support
BSOD with install of Intel Graphics driver or install of graphics card BSOD Help and Support
Graphics Card - Install New Card Tutorials
Solved can i install a graphics card to this motherboard? Graphic Cards
New Graphics card wont install. Graphic Cards
Install issue with my graphics card Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:29 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33