Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Latest NVIDIA ForceWare Video Drivers Windows 7

23 Feb 2012   #1201

Windows 7 Professional 64-Bit w/ SP1
 
 

I can't wait for ME3! Played Arkham City for over two hours and had zero problems, couldn't make out any difference in Physx but didn't expect to either.

My System SpecsSystem Spec
.

24 Feb 2012   #1202

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Nvidia has released the 9.12.0213 PhysX drivers. These are newer than the PhysX version included in the latest 295.73 WHQL graphics drivers.

NVIDIA DRIVERS 9.12.0213

A Guy
My System SpecsSystem Spec
24 Feb 2012   #1203

Windows 7 Ultimate SP1 (64-bit)
 
 

Thanks, Bill! Downloading...

BTW, This drivers are OK, i still haven't seen the "up to 40% performance boost in Skyrim" but i have seen improvements! Working like a charm with my GTX 560 Ti
My System SpecsSystem Spec
.


24 Feb 2012   #1204

Windows 7 Pro. 64/SP-1
 
 

No problems with the new driver on my GTX-460. Ran a FurMark test, so far things are good.
My System SpecsSystem Spec
24 Feb 2012   #1205

Windows 7 Home Premium 64bit
 
 

So far so good. Only 1 minor issue for me, and thats with Video Playback.

Not sure why, but if I have Dynamic Contrast enabled, it get some odd artifacts in dark areas playing back with Nero.
It doesnt happen on the older driver.

I just disabled it, and its OK even with HW acceleration enabled. Not sure whats going on there ....
My System SpecsSystem Spec
24 Feb 2012   #1206

Windows 7 Professional x64 SP1
 
 

Quote   Quote: Originally Posted by Wishmaster View Post
So far so good. Only 1 minor issue for me, and thats with Video Playback.

Not sure why, but if I have Dynamic Contrast enabled, it get some odd artifacts in dark areas playing back with Nero.
It doesnt happen on the older driver.

I just disabled it, and its OK even with HW acceleration enabled. Not sure whats going on there ....
After installation i always disable (on my previous HD5770, too) all the auto/dynamic video playback thingies. I like my video unprocessed
My System SpecsSystem Spec
24 Feb 2012   #1207

7 Ultimate 64 bit Service Pack 1
 
 

working fine maybe even better with my GeForce 9600M GT
My System SpecsSystem Spec
26 Feb 2012   #1208

Windows 7 Home Premium 64bit
 
 

Hmmm .. noticed another minor issue.

If my monitor goes to sleep, after waking it again launching a app that requires Admin rights causes a small issue.
The screen just goes black, and hangs a second before the prompt (and sound) comes up.

It only happens after bringing the monitor out of sleep. I rolled back to the previous driver, the issue was gone. Updated to new one, and the issue returned.

So I know its the driver, but Im unsure if its some sort of issue between the driver and my Motherboard.


Can anyone reproduce it?
My System SpecsSystem Spec
26 Feb 2012   #1209

Windows 7 Ultimate 64 Bit
 
 

Quote   Quote: Originally Posted by GeneO View Post
Quote   Quote: Originally Posted by Wishmaster View Post
Quote   Quote: Originally Posted by Seven Eleven View Post
Updated over 285.62 (didn't install 3D stuff). Played DA:O for a few hours and so far it's solid for me.

Thanks. Ill go ahead and try it out, was just curious what everyone else thought
I had to run beta drivers since the last official release because of some bug that was only fixed in beta. I replaced my P55/i5-760 with a P8Z68/i5 2500k, same graphics card, same driver. I was getting frequent random freezes and hangs all over the place and thought it was the new hardware. The freezes disappeared as soon as I updated to this release, so it is AOK in my book
I was getting freezes too, thought it was my hardware too, just upgraded and I've had a few problems since. The freezes were annoying but it seems since these drivers have installed, there isn't a problem now (hopefully). Are you still getting problems? and when did your comp freeze?
My System SpecsSystem Spec
26 Feb 2012   #1210

Windows 7 Home Premium 64bit
 
 

Im back to 285.62 for now, as its pretty stable for me.

Only seeing that delay when a UAC prompt is initiated the first time after the monitor came out of sleep. Afterwards, its fine untill the monitor sleeps again.
My System SpecsSystem Spec
Reply

 Latest NVIDIA ForceWare Video Drivers Windows 7




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:14 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33