Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Latest NVIDIA ForceWare Video Drivers Windows 7

22 Sep 2012   #1291

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by taylorig View Post
I'm still on 285.62 driver's
Same here . No issues at all with this version so sticking with it.

Everytime I upgrade theres always something not right. The last time it would freeze a second and the screen go black everytime the monitor came out of sleep.


But, haven't tried the newest yet, and probably won't. ATM, theres no need to.

My System SpecsSystem Spec
.

22 Sep 2012   #1292

Windows 7 x64 Ultimate SP1
 
 

Could anyone check if video decoding acceleration is still working on Flash videos on Nvidia graphics? I have an Optimus sistem, and it works on Intel but falls back to software on Nvidia. It's been like that the last couple of Flash versions.

Btw., 301.42 remains the best driver for me.
My System SpecsSystem Spec
10 Oct 2012   #1293

Windows 7 x64 Ultimate SP1
 
 

Another driver; 306.97, another ridiculous drop in WEI for me, from 6,7 to 5,1 in gaming graphics. I didn't even bother to test it in games. Back to 301.42.
My System SpecsSystem Spec
.


10 Oct 2012   #1294

Windows 7 Professional 64 bit
 
 

Quote   Quote: Originally Posted by Teerex View Post
Another driver; 306.97, another ridiculous drop in WEI for me, from 6,7 to 5,1 in gaming graphics. I didn't even bother to test it in games. Back to 301.42.

Thanks for the link, my WEI stayed the same, will test on some games later.
My System SpecsSystem Spec
10 Oct 2012   #1295

Windows 7 x64 Ultimate SP1
 
 

Quote   Quote: Originally Posted by paulpicks21 View Post
Quote   Quote: Originally Posted by Teerex View Post
Another driver; 306.97, another ridiculous drop in WEI for me, from 6,7 to 5,1 in gaming graphics. I didn't even bother to test it in games. Back to 301.42.

Thanks for the link, my WEI stayed the same, will test on some games later.
Did you clear the old results?

The reason why it falled on its face on my system is because it failed the DX10 batch test completely, result being 0 fps. Other than that, other tests are good. Can anyone confirm that? Maybe it was an one-off glitch... but I would prefer not to reinstall drivers again before someone else checked this.

I have an Optimus system btw.
My System SpecsSystem Spec
10 Oct 2012   #1296

Windows 7 Professional 64 bit
 
 

No, in fact I didn't even re run the whole assessment, I just refreshed the score and it just re ran the graphics tests.
My System SpecsSystem Spec
10 Oct 2012   #1297
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Quote   Quote: Originally Posted by Teerex View Post
Another driver; 306.97, another ridiculous drop in WEI for me, from 6,7 to 5,1 in gaming graphics. I didn't even bother to test it in games. Back to 301.42.
Thank you Tomislav. First post updated.
My System SpecsSystem Spec
10 Oct 2012   #1298

Windows 7 Ultimate SP1 (64-bit)
 
 

Hmm... Weird, I found the driver on geforce.com but not on nvidia.com

Anyway, I'll be testing it before going to class... Let's see what's going on with this release
My System SpecsSystem Spec
10 Oct 2012   #1299
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Quote   Quote: Originally Posted by Punkster View Post
Hmm... Weird, I found the driver on geforce.com but not on nvidia.com

Anyway, I'll be testing it before going to class... Let's see what's going on with this release
I guess they haven't fully updated the download links there yet. I had to look under 300 series or less for 306.97 to show.
My System SpecsSystem Spec
12 Oct 2012   #1300

Windows 7 x64 and numerous virtual machines
 
 

Installed the latest driver 306.97 on my wife's computer. She has a Giga Byte GT450 and dual boots between 7 64 bit and XP. 7 was easy no issues at all. XP update was a nightmare. Had to fight with it for 3 hours to get the driver to install correctly. The install software would quit. I had to uninstall the driver from the control panel, reboot then stop the auto install of the driver by the found new hardware wizard. Boot to safe mode, use Drive Sweeper 2.1 to clean away everything and finally got the driver installed correctly. Just the basic driver, the updater and other software installer still quit and she does not use it so I quit fooling with it too. It never used to be this hard. If you are still on XP (my wife loves it...don't ask) and you are not a serious gamer, leave well alone.

Forgot to mention on my machine with a GT9800 the windows score is 5.8 and the install was fine on the 64 bit versions of 7 but hung on the 32 bit but seemed to have installed everything.


Attached Thumbnails
Latest NVIDIA ForceWare Video Drivers Windows 7-screenshot001.jpg  
My System SpecsSystem Spec
Reply

 Latest NVIDIA ForceWare Video Drivers Windows 7





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:39 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33