Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Latest NVIDIA ForceWare Video Drivers Windows 7


25 Aug 2009   #431

Win 7 Ultimate 64 RTM
 
 

These drivers 190.57 are dated (20.08) , they are newer than the 190.62 (17.08)

My System SpecsSystem Spec
.

25 Aug 2009   #432

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

I might try them in my Win 7 boot at least to see if they handle the 59/60hz issue better.
My System SpecsSystem Spec
25 Aug 2009   #433

7600x64 ultimate, not SP1
 
 

Am I doing something wrong by simply downloading the file from the website and trying to install it? It says the system was not modified. Device manager says no drivers are installed for the device
My System SpecsSystem Spec
.


25 Aug 2009   #434

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

Well they didn't cure the 59/60hz refresh rate controversy in Win 7, however they did cure something else.
No drivers hitherto have allowed this to happen - now both GPU1 and GPU2 on my GTX295 throttle back to half power when the machine is quiet. With previous drivers only GPU1 did that.
My System SpecsSystem Spec
25 Aug 2009   #435

Win 7 Ultimate 64 RTM
 
 

Quote   Quote: Originally Posted by Ex_Brit View Post
Well they didn't cure the 59/60hz refresh rate controversy in Win 7, however they did cure something else.
No drivers hitherto have allowed this to happen - now both GPU1 and GPU2 on my GTX295 throttle back to half power when the machine is quiet. With previous drivers only GPU1 did that.
Cool !
My System SpecsSystem Spec
26 Aug 2009   #436

Windows 7 Ultimate Edition x64
 
 

yup, still shows up as 59 on new driver, lets see if evga precision will show correct reading now on this latest driver.
My System SpecsSystem Spec
26 Aug 2009   #437

Windows 7 Ultimate x64
 
 

anybody see any problems with these newer drivers where the GPU fans spin up during gaming and then don't spin back down once machine has cooled down? I moved the 190.38 drivers...and had this problem with my eVGA 9800GTX+. I went back to the 186.x drivers and everything was working as it should. I haven't yet moved off the 186.x drivers as they have been working good for me.
My System SpecsSystem Spec
27 Aug 2009   #438

Win 7 Ultimate 64 RTM
 
 

Nvidia 186.82 WHQL at Microsoft Update

Quote:
version 186.82 for Windows Vista and Windows 7 is now available. They originate from Microsoft Update and are compatible with just about every GPU from the GeForce 6 generation onwards due to the NV_WHQL.inf file in the packages, regardless of OEM
from guru
Quote:
They are dated 20/08
if you want to install these as international version. I had to delete the NvCplSetupEng.exe otherwise it always installs english control panel. Somehow Microsoft bundled both control panels, english and international.
My System SpecsSystem Spec
27 Aug 2009   #439

Windows 7 Professional x64 SP1
 
 

Quote   Quote: Originally Posted by pparks1 View Post
anybody see any problems with these newer drivers where the GPU fans spin up during gaming and then don't spin back down once machine has cooled down? I moved the 190.38 drivers...and had this problem with my eVGA 9800GTX+. I went back to the 186.x drivers and everything was working as it should. I haven't yet moved off the 186.x drivers as they have been working good for me.
I have the exact same card as you, and I did have some instances where under heavy load due to gaming, the fan would speed up and get rather loud, but it seemed almost random. I could play Fallout 3 one day for 2 hours and have the fan on the card get REALLY loud, and play the same game the next day, for the same length of time, without any fan speed increase at all.
My System SpecsSystem Spec
28 Aug 2009   #440

Windows 8.1 Professional x64
 
 

I don't have any fan problems or problems with the core/memory speeds with the 190.xx drivers, but they just don't feel as smooth to use as 185.85. I had 190.62 installed, and using my computer felt slower and more sluggish and I lost all the HD monitor options in Nvidia control panel, but I get all the options with 185.85.

I also get a few problems with some games when using 186.18 and upwards. The 3D driver stuff has messed Star Wars Galaxies up for me and it takes forever to alt+tab out of games, even if I uninstall the 3D drivers, it's still sluggish.

Guess I'll be on 185.85 forever now
My System SpecsSystem Spec
Reply

 Latest NVIDIA ForceWare Video Drivers Windows 7




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:04 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33