Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 5970 Crashing on bootscreen after driver install

02 Feb 2010   #1

Windows 7 x64
5970 Crashing on bootscreen after driver install

Tried everything i know and read to try to solve this problem. Windows works fine with all the drivers from the other components and rs's fine. If i install the ATI drivers it crashes on bootscreen.

Tried both the drivers that came with it and the new 10.1 divers.

The card worked fine the first 2 weeks then crashed and wouldent start. After a fjew formats and poking around i it worked fine for 1 more week and now its crashing again.

My System SpecsSystem Spec
02 Feb 2010   #2

Windows 7 Professional x64


It sounds as if the ATI drivers are causing the issue. Try just using the generic drivers Windows 7 provides. If you want, you can go into Device Manager, right-click on your card, and select Update driver software.

Hope this helps,
My System SpecsSystem Spec
02 Feb 2010   #3

Windows 7 x64

The windows 7 standar vVGA drivers kinda limits my 3d card to the point its useless, since i have had it working fine before. And automatic updates only tells me its up to date. Pinpointing the specific location of the downloaded drivers dont realy do much either since it either ends up the same way, that windows does not boot or it cant find them.

I hope some one knows how to fix the problem.
My System SpecsSystem Spec

03 Feb 2010   #4

Windows 7 Ultimate x64

Look Here for a possible solution:

Hopefully that will help.

I have been relegated to "Driver Hell" myself. The 10.1 drivers are causing me no end of grief....Flickering on my second monitor, a BIG Cursor glitch that was supposed to be fixed in the latest drivers release, just a bunch of crap dealing with these particular drivers. The 10.2 beta drivers cause unbearable flickering, and even the 10.1 Hotfix causes the second monitor flicker. (this is evidently caused by the video card setting itself too low in standby mode..but I have my doubts....nothing I have tried so far has really helped.

My option (and maybe yours, if the above link does not work magic for you) is to download an older version of the catalyst drivers.
My System SpecsSystem Spec
03 Feb 2010   #5

Windows 7 Ultimate x64

It is really frustrating when you spend $$$$$ on what is supposed to be the top-notch video card then you have to deal with all of the problems that come with the drivers.
ATI really needs to get their act together when it comes to video drivers...I had head that many times in the past...and I had stuck with nVidia cards for pretty much that reason, but I had HOPED that when AMD took over ATI that things would improve.
So far, I am not impressed.
Granted that all video cards have some driver issues now and then, but this ongoing issue with ATI drivers is ridiculous.

I don't know if you have done this or not, but with your driver problems you might give it a try.
(download driver cleaner pro)
Un-install the catalyst drivers, reboot into safe mode and run DriverCleaner to get rid of all ATI driver remnants.
Reboot, then install the drivers you wish to use (or try).
My System SpecsSystem Spec
03 Feb 2010   #6


Not sure if this may be of help, but you can remove your GFX card, plug your monitor into your mobo using your boards vpu to atleast download and install new drivers. That is if you're having issues not being able to even boot into windows. And that is of course if your board does have a gpu.
My System SpecsSystem Spec

 5970 Crashing on bootscreen after driver install

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Preload ATI 5970 Drivers to Install Disc
Hey, Anyone know of a way to have ATI CCC install during a clean install of windows 7 so that none of the original windows vga drivers are ever loaded? Just a curiosity I had :cool:
Crashing after Catalyst Driver 10.12 Install
Hello all, I am hoping I can call on your help once more to analyze some debugging info. I recently installed ATI Catalyst 10.12 drivers and now whenever my system is idle for too long, the screen just goes black but the monitor is still powered on and the system is unresponsive. I have my...
BSOD Help and Support
Win 7 x64 crashing my HD 5970
Hi, A couple of days ago I build a new system with the following specs: Intel Core i7 920 ASUS P6T Deluxe V2 OCZ Platinum XTC 6GB DDR3-1600 CL7 triple kit Sapphire Radeon HD 5970 2GB Western Digital Raptor 150GB Creative Sound Blaster X-Fi Xtreme Gamer Fatal1ty Professional...
Graphic Cards
Bootscreen Little(BIG) problem
Hello to all and Merry Christmas. I am new to this forum and I have a problem with my Windows 7 bootscreen. I searched everywhere but I didn't found any solution. The problem is that when the bootscreen is showing, the animation plays just a bit and then it freezes, but windows boots ok. How do I...
General Discussion
corrupted bootscreen
I have a strange problem. I installed W7 on a fresh partition, install went smooth but during the install (when I need to input name, pc name, keyboard etc.) the screen got corrupted (I can barely read where to click yes or no). As soon as W7 is started the screen is perfect. Booting W7 the screen...
Graphic Cards
Vista BootScreen in Windows7
Who noticed the Vista Bootscreen being used somewhere in Windows 7? :huh: You might find it built into a specific function? :p
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:42.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App