Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Ati Radeon X300 Windows 7 Issue

04 Feb 2010   #1
sere83

Windows 7 X64 Ultimate
 
 
Ati Radeon X300 Windows 7 Issue

Hi everyone,

I am having a problem with an ati radeon x300 driver and just wondered if you might be able to help?

I basically did a clean install of windows 7 on my pentium 3.0ghz with 3gb ram and everything worked great.

However.....I installed an updated video driver for my x300 and installed photoshop cs4 and also a reg entry which adobe offer to force enable hardware acceleration when the option is not available in your display adaptor properties.

Anyway since I installed cs4 and ran the new drivers and reg entry flash video playback within all my browsers has suffered.

It is ok when small, but when full screen it drops frames although it is not that bad at all just irritating. Another thing i noticed is 720p youtube playback is very laggy and before it used to play fine.

Anyway i booted in XP (i have a dual boot system) and tried to run flash videos and they did the same. However in my Xp config I can lower the hardware acceleration which I did (by 1 notch) and it fixed the issue.

However in Windows 7 & I have this new driver installed which doesn't seem to support the changing of hardware acceleration. I amd pretty sure If I lower it it will be fine but I can't get to the setting.

I tried uninstalling the card and installing the older drivers in safe mode but it wouldn't let me. Does anyone know how I can lower hardware acceleration so I can get these videos playing back properly?

Any help hugely appreciated...

Btw its Windows 7 X64 Ultimate


My System SpecsSystem Spec
.
05 Feb 2010   #2
Frostmourne

Windows 7 Ultimate x86-64
 
 

Roll back with system restore after uninstalling Photoshop. The reg fix most likely broke something in 7 - don't apply it. As for acceleration, in personalization, display, advanced settings, troublehshoot can do it, unless your card doesn't, so it will be grayed out, like my 4890.

I would install the newest available drivers, DirectX, flash, and Windows Updates.
My System SpecsSystem Spec
07 Feb 2010   #3
sere83

Windows 7 X64 Ultimate
 
 

Hi thanks for your reply. Unfortunately even after system restoring the problem seems to return. I also had to manually delete some of the cs4 install as it refused to uninstall.

I have all the newest drivers, flash and windows updates.

What is confusing me is that it actually was working fine before the ps install. I cannot change acceleration as it is greyed out. I don't think the new drivers support it. I think that maybe the reg fix might has done irreversible damage, although I did delete the reg entries.

This is very frustrating as all my flash video playback is choppy and I can't really watch anything full screen. Surely there must be something i can do to fix it? All the aero functions in win 7 work fine too.

I had thought about getting a new graphics card the Radeon Ati HD5450 perhaps as it supports directx11 but i believe my fan is only 350w and to run a card like that it needs to be more powerful.

Can you offer any advice on anything else I could try?
My System SpecsSystem Spec
.

08 Feb 2010   #4
Frostmourne

Windows 7 Ultimate x86-64
 
 

Can you undo the restore point, uninstall CS4, then restore back to another point?
My System SpecsSystem Spec
Reply

 Ati Radeon X300 Windows 7 Issue




Thread Tools




Similar help and support threads
Thread Forum
Driver issue in windows 7 (ATI Radeon Mobility 4670)
Quick summary of my issue: I just bought a new acer (link) and proceeded to install windows 7 (64-bit) straight ahead. I must admit i made a bit of a mistake when i didn't check if the box it got shipped in contained any drivers or such (which it didn't to my surprise!) Currently got experience...
Graphic Cards
Windows Aero Effect on ATI MOBILITY RADEON X300 Card
i have installed windows 7 recently on my dell 6000 inspiron, it has ATI MOBILITY RADEON X300 Card 2GB ram, but iam not able to experience Windows Aero Effect, i have tried roubleshooter, but still iam unable, PLEASE HELP!
Graphic Cards
ATI mobility radeon X300 drivers
Hi, i recently installed windows 7 on my Dell Inspiron 6000. No aero effect as my video card driver was not installed. Could any body help me where to get drivers and how to install it for my video card please? Thanks.
Graphic Cards
Radeon X300/X550/X1050 Series
Can any1 help me with this driver for windows 7 , or at least for vista x64 , i'm a little bit nubbish with the search on google i found only catalist but didn't found the driver. Thanks
Graphic Cards
Windows 7 Radeon HD3470 issue.
Hi, I'm on the verge of putting my foot through my girlfriends laptop, it's an Acer Aspire 5920G running Windows 7 X64. It seems that windows has installed it's stored version of the driver (version 8.56.1.15) the problem being this is causing issues in Maya and she needs the latest version....
Graphic Cards
ati radeon x300/x550/x1050 series
my card has a dvi/ vga and svideo in xp im able to have dual monitor with the second monitor and tv as clones so vga and svideo are same and an extension of the dvi monitor. the upgrade advisor says my card does not support aero im not sure what that means as it works great in 7 except i cant view...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App