Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 4890 ati strange problem in win7

08 Mar 2010   #1
vlajko80

windows 7
 
 
4890 ati strange problem in win7

System is a custom built, with all new components.
CPU: Phenom II X4 955, Rev C3
MB: Asus m4a79xtd evo - 790x Chipset
RAM: 2 modules, Kingston KHX1600C9D3BK2/4G 4GB DDR3-1600Mhz
PSU: Lc-power 600 w
GPU: PowerC Ati radeon 4890 1gb ddr5

So the problem appeared when I installed win7 64bit. No problem what so ever on XP.

The games runes about (50-100) fps depends on the game, with apsolutly no lag but accompanied by some a kind of jerky motion. Some kind of frame problem. Relay i don't know how to describe it.I tried to reinstalled (formatted) the whole system. fresh drivers for the motherboard and graphics and still nothing.Updated my bios. Tried win7 32bit to. But when i downgrade to Xp, problem simply disappears. Does anyone know what the problem is and how to solve it? ...i don't want to return to Xp again

when I use XP, games like Battlefield BC2 works normal with the new Catalyst drivers. But the games such as GTA4 lags horribly. I solved the problem in XP (with GTA4), by rolling back to older version of catalyst. And with that older version every game works just fine, with high frame rates and no lag ...and without this kind of problem that i have on win7. On the other hand in win7 i have new catalyst driver no lags in games, high frame rates but i have this strange motion problems like missing frames or something ( its like "teleport" effect, when you are going forward ), overlapping frames...and all of that at frame rate of 80?
Its weird and i cant determine the cause of it?


My System SpecsSystem Spec
.
08 Mar 2010   #2
Desslok

Windows 7
 
 

Are these online games or local single player?
My System SpecsSystem Spec
08 Mar 2010   #3
vlajko80

windows 7
 
 

local.....i have .choppy gameplay despite high fps...... but when i run some background process like fraps ( movie capturing with f9 -function on ) that lower frame rate in game , problem disappear . How strange is that ??
My System SpecsSystem Spec
.

08 Mar 2010   #4
Frostmourne

Windows 7 Ultimate x86-64
 
 

Replace the cheapo PSU, then run Memtest86+ and schedule chkdsk.
My System SpecsSystem Spec
08 Mar 2010   #5
baron75mk2

 

just wondering when you say games running at 80 - 100 fps are you using v-synch (wait for vertical refresh) or does your monitor support inputs of 100hz ? i find if i dont use v-synch i get the same issues - i get phenominaly high framerates but because the graphics card & hdtv/monitor are not syncroinised properly i get the teleport effect you discribed & the ususal screen tearing as well - so these days i just have v-synch enabled & run at 60fps/60hz ( highest my hdtv supports) with no issues apart from far cry 1 which i still get the teleport issue with but this is due to the game being so old & not really compatible with the newer cards/drivers
My System SpecsSystem Spec
09 Mar 2010   #6
vlajko80

windows 7
 
 

Quote   Quote: Originally Posted by baron75mk2 View Post
just wondering when you say games running at 80 - 100 fps are you using v-synch (wait for vertical refresh) or does your monitor support inputs of 100hz ? i find if i dont use v-synch i get the same issues - i get phenominaly high framerates but because the graphics card & hdtv/monitor are not syncroinised properly i get the teleport effect you discribed & the ususal screen tearing as well - so these days i just have v-synch enabled & run at 60fps/60hz ( highest my hdtv supports) with no issues apart from far cry 1 which i still get the teleport issue with but this is due to the game being so old & not really compatible with the newer cards/drivers
wait ?
my monitor refresh rate is set to 60hz?
i tried to enable Vsync from CCC and from the game and still nothing ??
Yes in the game i have high frame rate, i dont know how ?
Can you enplane me what to do ???
My System SpecsSystem Spec
09 Mar 2010   #7
vlajko80

windows 7
 
 

Quote   Quote: Originally Posted by Frostmourne View Post
Replace the cheapo PSU, then run Memtest86+ and schedule chkdsk.

why do you think is PSU ??
Everything is normal in xp , only in win7 i have problem.
600w is more than enough
My System SpecsSystem Spec
09 Mar 2010   #8
vlajko80

windows 7
 
 

ok so , according to this Thermaltake Power Supply Calculator
i need a 350w psu ?
My System SpecsSystem Spec
09 Mar 2010   #9
Frostmourne

Windows 7 Ultimate x86-64
 
 

Quote   Quote: Originally Posted by vlajko80 View Post
ok so , according to this Thermaltake Power Supply Calculator
i need a 350w psu ?
Cheap PSU's can have all kinds of screwy issues.
My System SpecsSystem Spec
Reply

 4890 ati strange problem in win7




Thread Tools





Similar help and support threads
Thread Forum
raideon 4890 problem
I just kinda revamped my system, I got a new case< added 3 raid hard drives, and windows seven, I am so dissapointed, it feels like I a have to go buy all new stuff my lagitech wireless mouse and keyboard drivers dont load all the way, my video that was producing 7.1 suround sound, is now only on...
Drivers
XFX 4890 fan problem...what would they do?
Hey guys, The fan on my 4890 has been making wierd buzzing noises on/off for some time now,at least 4 months,It seems to only do it though when the fans rps slows down and the fans spinning around 50% speed,If i raise the speed of the fan the noise goes but im thinking that the fan will...
Graphic Cards
Problem With Windows 7 Pro 64Bit and Radeon HD 4890
ok... So i feel like i have tried everything but I'm sure i haven't because if i did it would be working here's my problem and a time line. Preorder'd win 7 got it on the 22nd installed it yesterday. it immediately ran windows update, during that update it installed the drivers for my GFX...
Drivers
[Win7]Strange problem(gaming)
Hi guys, I installed windows 7 a month ago (now got rid of it). And I got a strange problem when playing games. I installed drivers from WIndows 7 updating system, acer site and from laptopvideo2go. but they all failed for me. (I could install them, but same problem) The problem is : When...
Gaming
Problem with Radeon 4890 with Sony Bravia HDTV
Hello, The problem is that for some reason I cannot get a pixel perfect screen to the Sony Bravia Full HD LCD TV with the Radeon 4890. There are always black borders around the screen. Have the Catalyst 9.11 Suite for Windows 7 (64 bit) installed. With a Nvidia 8800gt there is no need for...
Graphic Cards
ATI 4890 HD on Windows 7 Professional 64 bit problem
Alright here is my problem i recently installed my computer with the Windows 7 Professional 64bit version. (Got it from my MSDN) I updated all my ATI Drivers and that Catalyst thing http://game.amd.com/us-en/drivers_catalyst.aspx?p=win7/windows-7-64bit I Installed all the Windows 7 updates so...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App