Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Gainward HD 4870 X2 on w7

27 Mar 2010   #1

Windows 7 Ultimate x64
 
 
Gainward HD 4870 X2 on w7

Hey everyone. I'm not sure if this has been posted before, if it has i apologize, as i could not find a thread that matched my issue.

So basically this is the problem:

A friend of mine told me to get a windows 7 cd because it was better than the OS i was previously running (Windows Xp Pro SP3), so i did, i got the 64 bit ultimate version, and i installed it without error.

Now that the installation is done, it would proceed to the desktop, where windows 7 had (to my suprise) installed pretty much all my drivers. The only problem is, that it was lagging terribly.

Imagine that you set your taskbar to hide itself automatically right? Now imagine yourself sliding your mouse down to the taskbar, to make it show itself. This action is used many times a day, but for me, it takes the taskbar about 15-20 seconds to show after i put my mouse to it.

This goes for everything too. When i double click a random folder, it takes the folder about the same amount of time to start, and it's just really acting slow. If i open google to do a quick search, the text i write comes after i've actually pushed the keys on my keyboard, it's unbelievably annoying!

So thats the problem, the thing is, that when i deactivate the driver for my graphic card, the lag stops immediately, i can use windows normally, and it responds perfectly to every single click i make, so ofc. i thought that windows 7 gave me a wrong driver.

I've since then tried to download and install pretty much every single driver for my graphic card, with no success so far. So now i'm asking you guys, cause i'm sure if anyone knows, the answer lies here

Just to let you know, when i had windows Xp installed, i downloaded my display drivers directly from Gainwards website, because my mate told me that the drivers there are optimized for my card. Problem is, since i got windows 7, i can't get my drivers from Gainwards website, because now they only show nvidia cards as a driver download solution, so all drivers i've installed so far has been from ati's website.

My System SpecsSystem Spec
.

27 Mar 2010   #2

Windows 7 Ultimate x64
 
 

Yeah, if they're not offering Windows 7 support, then there's nothing you can do about it but rely on the ATI drivers.
My System SpecsSystem Spec
27 Mar 2010   #3

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Zen00 View Post
Yeah, if they're not offering Windows 7 support, then there's nothing you can do about it but rely on the ATI drivers.
I'm pretty sure it's not because i have windows 7, it's just that they don't support radeon drivers anymore, so i can't get them from there.
My System SpecsSystem Spec
.


27 Mar 2010   #4

 
 

Quote   Quote: Originally Posted by Tanis View Post
i downloaded my display drivers directly from Gainwards website, because my mate told me that the drivers there are optimized for my card
lol. It would be nice if that were true. Too bad they'd be several versions behind that would rarely have the latest game fixes


Anyway, what version driver version are you running now?

The latest official drivers are Catalyst 10.3

It may be worthwhile unistalling the current drivers, running driver sweeper in safe mode and then rebooting normally and installing the latest drivers.

http://www.guru3d.com/category/driversweeper/
My System SpecsSystem Spec
27 Mar 2010   #5

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by smarteyeball View Post
Quote   Quote: Originally Posted by Tanis View Post
i downloaded my display drivers directly from Gainwards website, because my mate told me that the drivers there are optimized for my card
lol. It would be nice if that were true. Too bad they'd be several versions behind that would rarely have the latest game fixes


Anyway, what version driver version are you running now?

The latest official drivers are Catalyst 10.3

It may be worthwhile unistalling the current drivers, running driver sweeper in safe mode and then rebooting normally and installing the latest drivers.

Guru3D - Driver Sweeper
Well as i stated, i pretty much tried every driver, and i have used driver sweeper and updated to the latest version (10.3) without any luck, the system is still acting like i'm on a commodore 64
My System SpecsSystem Spec
27 Mar 2010   #6

Windows 7 Ultimate x64
 
 

There are some 10.3b drivers, there's a link to them in the Catalyst drivers thread.
My System SpecsSystem Spec
27 Mar 2010   #7

 
 

Quote   Quote: Originally Posted by Tanis View Post
Well as i stated, i pretty much tried every driver, and i have used driver sweeper and updated to the latest version (10.3) without any luck, the system is still acting like i'm on a commodore 64
I know you stated you tried different versions, but you didn't mention using driver sweeper

Are both cards and all cores being detected?
My System SpecsSystem Spec
29 Mar 2010   #8

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by smarteyeball View Post
Quote   Quote: Originally Posted by Tanis View Post
Well as i stated, i pretty much tried every driver, and i have used driver sweeper and updated to the latest version (10.3) without any luck, the system is still acting like i'm on a commodore 64
I know you stated you tried different versions, but you didn't mention using driver sweeper

Are both cards and all cores being detected?
I know i didn't, but i am using it

Anyways, it detects everything, both cores on gpu and cpu, ram, hd, i get no error other than i have no driver installed for my graphics card, because i have to keep it disabled in order to use the computer.

I really don't want to go back to xp, since i actually like Windows 7 quite a lot.. so i hope someone out there has an answer that'll help me.
My System SpecsSystem Spec
Reply

 Gainward HD 4870 X2 on w7





Thread Tools



Similar help and support threads for2: Gainward HD 4870 X2 on w7
Thread Forum
GTX 580 Gainward Phatom 3GB on BIOSTAR TH55B-HD motherbored Graphic Cards
Opinions on gainward gpu's Graphic Cards
Gainward Geforce GTX 460 1GB golden sample Graphic Cards
Ati hd 4870 Graphic Cards
Win 7 refuses Gainward 4850 GS (1024 MB) Graphic Cards
Oc 4870 Graphic Cards
Gainward HD4830 Desktop problem Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:10 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33