Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 9800GT Black screen only with Win7/Vista x65 drivers

19 Apr 2009   #1

Windows 7 7077
9800GT Black screen only with Win7/Vista x65 drivers

I got a Asus P5Q-E Mobo, 8gb ram
Having Win7 7077 x64 installed for one week and before the upgrade nearly 2 months with build 7000.
I bought a new gpu, and replaces my old 8500GTS with a new 9800GT,
Problem is, Windows find the gpu, installs standard driver. all fine.

Second, Install new Win beta 7 Drivers (was trying new vista x64 drivers too), and i got black screen and lockup half time in install progress and when doing a hard restart right before Loginscreen also.
Restart, and windows is doing reset, and old drivers back.

Trying to install several times. no luck with any settings or admin settings to install, same problem, black restart black reset, black restart black reset, black restart black reset.... etc etc.
Putting back the old gpu, install same drivers, power of, putt new gpu in, and its getting black...

What is the problem? I cant find any info in systemlogg either, but the gpu works with standard drivers from windows

I hope i havent missed anything

Best regards /T

Edit: My psu is Corsair 650w, i got 10 HDs, and it uses max 220-260w what i have tested, a bit more while playing (old gpu)

I will get a Vertex SSD this week, maybe the problems solves when installing a fresh Win7 on it? Otherwise i hope someone knows the issue.

Updated Bios on Mobo, Adaptec 2405 and Rocketraid 2320, Still same issue.

I have noticed that the HD led blinks all the time with that gpu, and its gets very hot...
I plugged out the power of my 2x5hds hotswapmodule, so only one hd was active and same error accured, The problems dissapears when i but pack the old gpu.

My System SpecsSystem Spec
16 Oct 2009   #2

Windows Vista

I don't know if this will help or not but i had a similar problem with my XFX 9800GT on my current motherboard which is Asus P5QL PRO. Windows Vista default VGA drivers works fine but for some strange reason i can't install any drivers from NVIDIA regardless of what version from 17x.x, 18x.x even the latest 19x.x.

Upon installation of drivers and restarting, windows vista loading bar finishes loading, the screen goes to a black screen. I can't even enter windows unless i remove the drivers in safe mode and go with the default VGA drivers.

The only work around i had was to trade my graphic card with another friend which was using a MSI 9800GT and it suddenly able to load into windows with the latest drivers.

The only similarity i could find between yours and mine is that our motherboard is from ASUS. I suspect there might be a conflict. I also read on other forums some other users using ASUS motherboard can't update to the latest drivers and stuck and 182.50. Well i can only speculate . Hope my situation gives you some ideas on how to solve this problem.
My System SpecsSystem Spec
25 Oct 2009   #3

Windows 7 (64 bit)

I have the same problem. Can't install the 9800GT drivers on Win 7 64 Bit OS. I migrated from Win XP Pro 32 Bit OS. However, I have a Gigabyte GA-P35-DS3L motherboard.
My System SpecsSystem Spec

25 Oct 2009   #4

Windows 7 (64 bit)

I finally managed to install the latest Nvidia drivers -- by updating motherboard drivers -- however I still get the black screen of death.
My System SpecsSystem Spec
25 Oct 2009   #5

Win 8 Release candidate 8400

Quote   Quote: Originally Posted by alexunlv View Post
I finally managed to install the latest Nvidia drivers -- by updating motherboard drivers -- however I still get the black screen of death.

You are posting to a thread that is from april. Its usually better to sttart your own thread.

Now first thing try to boot in safe mode by hitting F8 repeatedly when booting.

Let us know the result

My System SpecsSystem Spec
26 Oct 2009   #6

Windows 7 (64 bit)

Thanks for the prompt response Anthony. However, I gave up and took an 8800GT card from another computer on XP and exchanged it with the 9800GT.

Anyhow, for other readers that have experienced similar problems. These are some of the steps I took to attempt to resolve this problem.

1. Booted into Safe Mode.

2. Used Driver Sweeper.

3. Selected Device, under devices, and "uninstalled."

4. Went to Control Panel and removed any sign of Nvidia from Programs/software.

5. Rebooted.

6. Booted into Safe Mode.

7. Installed latest Nvidia drivers.

8. System recognized the drivers, played around with resolution without a problem.

9. Rebooted = Black Screen of Death.

10. Booted into safe mode, with high resolution and the driver still looking good.

11. While computer was on, I switched the connectors from one to the other, but no go.

10. Turned off computer, and switched connectors. No go.

11. Attempted to Boot system by selected option to "boot with low? resolution 630?x???" - No go.

Note -- I tried this card on two different systems, sitting adjacent to each other and it is the same issue. However, the card works perfectly fine when I was running XP. Both have adeqequate PSUs, with good enough Motherboards.

---Note: Apparently some of the older Vista 64 Bit drivers work, such as 182.50. Atleast that may get you up and running until a fix is released.
My System SpecsSystem Spec

 9800GT Black screen only with Win7/Vista x65 drivers

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Urgent! Win7 will not load after lenovo boot screen, black screen
Hey guys I was installing kali from a usb drive, when it was partitioning the drive it crashed... So I turned off my lenovo g570 4334 laptop, pulled out the usb drive and booted my laptop up normally..... It loaded the lenovo screen, with the options to access bios, then loaded a black screen with...
General Discussion
Latest Nvidia 9800GT Drivers that work with Windows 7?
Hi guys! Ive been looking around on the internet to see which drivers work best with Windows 7 and it seems like 185.85 seems to be the best. But i was wondering as the post i found was from 2009, is there any of the new drivers working better with windows 7? I did see that 314.22 worked for...
Graphic Cards
Black screen after windows vista logo
Hello there! I'm having an issue with one of my windows Vista systems. It's a HP computer (blah, I know)... and is several years old. It's issue of late occurs on start-up. After attempting to "Start windows normally", the system will display the load screen then immediately go to a black screen....
BSOD Help and Support
when installing windows vista or 7 black screen with mouse?
I go a computer in today and it needed a chkdsk then maybe a repair so I was looking for the vista disk and couldnt find it my boss told me to put in a XP disk and just run chkdsk so i put it in pressed R then type chkdsk /P /R it stopped at 58 percent and it was the end of my shift so i left and...
BSOD Help and Support
Black Screen of Death on start up when upgrading from Vista to 7
Hi folks. I spent days and weeks to try and find a solution for the black screen of death that i was encountering after having upgraded my OS from Windows Vista to Windows 7. As soon as the upgrade process was over, instead of taking me back to my new Windows 7 desktop, the screen was black...
BSOD Help and Support
ATI Catalyst 9.7 RC3 Drivers for Vista/Win7 | x86\x64
The official WHQL drivers are out so go get em! :)

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:37.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App