Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Second monitor stopped working


05 Apr 2010   #1

 
 
Second monitor stopped working

I'm running Windows 7 64bit and have 2x Radeon 4870's crossfired, been running dual monitors fine on it since the day I've had it.

Shut my computer down before I went to bed last night and wake up this morning turn it on and my second display will no longer detect.

I've unplugged them both and turned off my computer for 20mins, checked and verified the plugs were fine numerous times over, installed the CCC tried the force detect and still nothing picks it up and I'm at my wits end someone help me before I break it pls!

My System SpecsSystem Spec
.

05 Apr 2010   #2

Windows 7 Profesional x86, Mac OS X 10.6 Snow Leopard
 
 

Hi, have you tried switching the monitors around so they are both plugged into the VGA/DVI/HDMI they are not usually in?

This will identify if it is a GPU problem or a Monitor Problem.

If it is a GPU problem you may consider doing a system restore to yesterday or the day before and see if that fixes anything.

Oli
My System SpecsSystem Spec
05 Apr 2010   #3

 
 

I've tried switching the monitors DVI plugs of which they are normally in, when I switch them I get no display whatsoever so is this a problem with my DVI slot on my video card?

I've also tried another DVI plug for my 2nd monitor that isn't working.

Also how do I do a system restore to a day prior if need be?

Thanks..
My System SpecsSystem Spec
.


05 Apr 2010   #4

Windows 7 Profesional x86, Mac OS X 10.6 Snow Leopard
 
 

There is a tutorial on how to do a system restore at System Recovery Options - Windows 7 Forums .

When you say you get no display at all do you mean neither screen is recognised?

Check your GPU drivers are both installed and up to date and that both GPUs are recognised in device manager.

Oli
My System SpecsSystem Spec
05 Apr 2010   #5

 
 

I just change the slot that the working monitor is in with the one that isn't showing anything and get no display from either when I do that.
My System SpecsSystem Spec
05 Apr 2010   #6

Windows 7 Profesional x86, Mac OS X 10.6 Snow Leopard
 
 

That would suggest to me that it's the monitor and the GPU that isn't working.

If possible try checking the monitor that doesn't seam to work with another PC.

Do both your GPUs appear in device manager?

Oli
My System SpecsSystem Spec
05 Apr 2010   #7

 
 

And where do I check if if GPU drivers for both are installed?

In my device manager under display tab both my video cards show up and the drivers are working properally and up to date.
My System SpecsSystem Spec
05 Apr 2010   #8

Windows 7 Profesional x86, Mac OS X 10.6 Snow Leopard
 
 

Quote   Quote: Originally Posted by Darksold13r View Post
And where do I check if if GPU drivers for both are installed?

In my device manager under display tab both my video cards show up and the drivers are working properally and up to date.
Your GPUs or Graphics Cards or Video Cards are all the same thing.

If they are both working, I would try disabling and re enabling both GPUs and see what happens.

I would also check in the BIOS (accessed by pressing F8 while booting up) if there is anything to do with GPUs or Graphics Cards or Video Cards, that has turned itself off.

Oli
My System SpecsSystem Spec
05 Apr 2010   #9

 
 

Ok, well I've come to the conclusion I'm just haunted with hardware with computers.

I unplugged it to take up to test on another computer in the house but was unable to try it. Returned with it to my computer and plugged it back in and voila it suddenly starts working again and both displays are back and working..... lol thanks for the help anyway osholt muchly apprciated.

Any idea why this would occur?
My System SpecsSystem Spec
05 Apr 2010   #10

Windows 7 Profesional x86, Mac OS X 10.6 Snow Leopard
 
 

Quote   Quote: Originally Posted by Darksold13r View Post
Ok, well I've come to the conclusion I'm just haunted with hardware with computers.

I unplugged it to take up to test on another computer in the house but was unable to try it. Returned with it to my computer and plugged it back in and voila it suddenly starts working again and both displays are back and working..... lol thanks for the help anyway osholt muchly apprciated.

Any idea why this would occur?
It could be a lot of things,

Dust;

Bad connection;

A manual reset after a power surge;

GPU being earthed and then being knocked back into position;

A little evil spirit manifesting itself which won't be satisfied until you've had to dismantle something. .


You have to remember (especially with older hardware) that it all has a very temperamental soul; for instance one of my USB hard drives will only work with one specific USB cable.

I'm glad your problem is fixed none the less.

As you are new to the forum I thought you might like to know how to mark threads as solved as well as the uses of some of the other buttons.

To the top right of this post you will see 3 icons. An orange (+), a set of scales and a red and white warning triangle.

The orange (+) or blue (-) denotes whether a user is on or offline (orange = on, blue = off).

The scales are used to give rep points; click this button if someone has helped you significantly or solved your queries (only give this to posts that you think really deserve it).

The red and white warning triangle is used to denote either an abusive post OR to mark a thread as solved (just put solved in the box that comes up and the admins or moderators will mark it solved).

Oli
My System SpecsSystem Spec
Reply

 Second monitor stopped working




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:35 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33