Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WOW will not load

06 Jun 2010   #1

windows 7
 
 
WOW will not load

I just finished upgrade from Vista to 7 and when I attempt to play WOW I get the following message "Failed to find suitable display device". I did have to remove the ATI manager from the system when upgrading but cannot find a replacement.

Everything else seems to work but the WOW game.

My System SpecsSystem Spec
.

06 Jun 2010   #2

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04
 
 

Quote   Quote: Originally Posted by rbillings View Post
I just finished upgrade from Vista to 7 and when I attempt to play WOW I get the following message "Failed to find suitable display device". I did have to remove the ATI manager from the system when upgrading but cannot find a replacement.

Everything else seems to work but the WOW game.
You should download the drivers from ATi's Website.

http://www.amd.com/us/Pages/AMDHomePage.aspx
My System SpecsSystem Spec
06 Jun 2010   #3

multiboot
 
 

Might try running as admin or checking the compatibility and setting it as Vista or XP as well, sometimes in Windows 7 things act wierd.
My System SpecsSystem Spec
.


06 Jun 2010   #4

Windows 7 Ultimate N
 
 

Most probably a driver issue. Compatibility isn't really a direct cause but could be the root of the problem.

Download and install the latest drivers for your gfx card. If you have any trouble be sure to post and tell us what graphics card you have so we can help you find the correct drivers to install.
My System SpecsSystem Spec
06 Jun 2010   #5

windows 7
 
 

Well I downloaded and installed the latest drivers for my video card, I have a Toshiba Satelite laptop, and now when WOW attempts to load I get the message it can't load the 3d accellarator and asks for directx 9.0c. I downloaded it and installed it and get the same message. I re-started the laptop just in case it was needed to complete the install but still get the same message.
My System SpecsSystem Spec
06 Jun 2010   #6

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04
 
 

Quote   Quote: Originally Posted by rbillings View Post
Well I downloaded and installed the latest drivers for my video card, I have a Toshiba Satelite laptop, and now when WOW attempts to load I get the message it can't load the 3d accellarator and asks for directx 9.0c. I downloaded it and installed it and get the same message. I re-started the laptop just in case it was needed to complete the install but still get the same message.
Try installing this; Download details: DirectX End-User Runtime
My System SpecsSystem Spec
Reply

 WOW will not load




Thread Tools



Similar help and support threads for2: WOW will not load
Thread Forum
Load IE8 on Win 7 Browsers & Mail
windows 7 refuses to load and system repair wont load BSOD Help and Support
Solved Help me to get CCC to load Graphic Cards
Album art takes long to load or doesn't load at all in explorer.exe General Discussion
Cant load WIN 7 Installation & Setup
IE8 will not load Browsers & Mail
Can XP Mode load a driver that won't load in Win 7? Virtualization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:35 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33