Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Startup issues with ATI 4870

08 May 2009   #1

Windows 7 64 RC 1
 
 
Startup issues with ATI 4870

I went to play Left 4 Dead on the 1.1 prerelease drivers and it crashed and locked up my system when loading a level. Since then, when ever i restart the computer my screen goes black at the login screen, i can log in but the screen stays black. The display works fine in safe mode. I deleted the video driver and then i can get back into windows, but when ever i reload the old 1.1 driver from windows update or the the latest driver from the ati website it goes back to a black screen when windows gets to the login screen.

Any help would be helpful.

My System SpecsSystem Spec
.

08 May 2009   #2

Windows 7 Home Premium x64
 
 

Try the WDM Catalyst 9.4 drivers. Make you get either the x32 or x64 versions for your OS.

Drivers & Tools | GAME.AMD.COM
My System SpecsSystem Spec
08 May 2009   #3

Windows 7 64 RC 1
 
 

i did, same thing.
My System SpecsSystem Spec
.


08 May 2009   #4

Windows 7 Home Premium x64
 
 

Post your specs, maybe it's a PSU problem?
My System SpecsSystem Spec
08 May 2009   #5

Windows 7 64 RC 1
 
 

e8400
4gb mushkin ram
ati 8750
Corsair 750watt psu
cant remember the mobo atm but i know it was a mid range asus
My System SpecsSystem Spec
08 May 2009   #6

Windows 7 Home Premium x64
 
 

The 750w should be more than enough. Did you do an upgrade or fresh install?
My System SpecsSystem Spec
08 May 2009   #7

Windows 7 64 RC 1
 
 

fresh install
it was working fine since i installed it until left 4 dead crashed
My System SpecsSystem Spec
08 May 2009   #8

Windows 7 Home Premium x64
 
 

Hmm, odd. Try clearing out any temp/tmp files. Also, L4D may have left a crashlog, see if it has any clues. . .
My System SpecsSystem Spec
27 Aug 2009   #9

7 Ultimate
 
 

L4d has issue with ieframe.dll in windows 7
i need to ctrl-alt-del to open task manager, open IE, close task manager, close IE, click L4D on the taskbar.
My System SpecsSystem Spec
27 Aug 2009   #10

ultimate 64 sp1
 
 

bizarre!

luckily my l4d doesn't have such problems.

quick tip, you can get to task manager quicker by using Ctrl-shift-Esc
My System SpecsSystem Spec
Reply

 Startup issues with ATI 4870





Thread Tools



Similar help and support threads for2: Startup issues with ATI 4870
Thread Forum
Startup Issues General Discussion
Issues on startup again BSOD Help and Support
msi fx600mx startup issues General Discussion
Please help - always startup issues... General Discussion
Every Other Day Startup Issues Win 7 Pro x64 BSOD Help and Support
Asus HD 4870 Issues Graphic Cards
Startup Issues Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:31 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33