Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Gigabyte ATI Radeon 4670 HD


25 Jul 2010   #1

windows 7
 
 
Gigabyte ATI Radeon 4670 HD

pls..i need help..if somebody who have using same GC above, can u give the original backup bios of your...i update my GC bios n then my display flickering....i need to restore back my GC bios

My System SpecsSystem Spec
.

25 Jul 2010   #2

Windows 7 Home Premium 64bit sp1
 
 

is this a pci-e card or agp ? cause i recall that card is in both formats anyway you can't get the update from the ati site itself ? or do you even have the original disc?
My System SpecsSystem Spec
25 Jul 2010   #3

Win 7 Home Premium 64 Bit
 
 

http://www.techpowerup.com/vgabios/i...ace=&memSize=0

back it up next time!!!

and..........i am not responsible for you screwing your card up if you flash it with anything ive linked you too , its your responsibility to check the linked files are good
My System SpecsSystem Spec
.


25 Jul 2010   #4

windows 7
 
 

Quote   Quote: Originally Posted by Solarstarshines View Post
is this a pci-e card or agp ? cause i recall that card is in both formats anyway you can't get the update from the ati site itself ? or do you even have the original disc?
i update it from ati site with new update for my GC n then that happen....

Quote   Quote: Originally Posted by archie123 View Post
techPowerUp! :: Video Bios Collection

back it up next time!!!

and..........i am not responsible for you screwing your card up if you flash it with anything ive linked you too , its your responsibility to check the linked files are good
i also have try this update also but didn't work...maybe it need the first BIOS provide for it self....
My System SpecsSystem Spec
25 Jul 2010   #5

Windows 7 Home Premium 64bit sp1
 
 

try uninstalling the driver and have windows give you a driver see if that works
My System SpecsSystem Spec
25 Jul 2010   #6

Win 7 Home Premium 64 Bit
 
 

Quote   Quote: Originally Posted by frantic912 View Post
Quote   Quote: Originally Posted by Solarstarshines View Post
is this a pci-e card or agp ? cause i recall that card is in both formats anyway you can't get the update from the ati site itself ? or do you even have the original disc?
i update it from ati site with new update for my GC n then that happen....

Quote   Quote: Originally Posted by archie123 View Post
techPowerUp! :: Video Bios Collection

back it up next time!!!

and..........i am not responsible for you screwing your card up if you flash it with anything ive linked you too , its your responsibility to check the linked files are good
i also have try this update also but didn't work...maybe it need the first BIOS provide for it self....
that is the original bios , that link is for the cards default bios , you have flashed the bios yes? your not just talking about the drivers are you?

what application did you use to flash the cards bios?
My System SpecsSystem Spec
25 Jul 2010   #7

windows 7
 
 

Quote   Quote: Originally Posted by Solarstarshines View Post
try uninstalling the driver and have windows give you a driver see if that works
still not works...
My System SpecsSystem Spec
25 Jul 2010   #8

windows 7
 
 

Quote   Quote: Originally Posted by archie123 View Post

that is the original bios , that link is for the cards default bios , you have flashed the bios yes? your not just talking about the drivers are you?

what application did you use to flash the cards bios?
yes..using WinFlash 2.0.11 i think....so if this default bios, i try flash it again using AtiFlash (DOS)

i update here later....thanks mate...
My System SpecsSystem Spec
27 Jul 2010   #9

windows 7
 
 

i already flash it using ATIFlash..everything fine when update but same problem still appears...
i already contact Gigabyte technical support for that issue n still waiting for their answer
My System SpecsSystem Spec
Reply

 Gigabyte ATI Radeon 4670 HD




Thread Tools



Similar help and support threads for2: Gigabyte ATI Radeon 4670 HD
Thread Forum
Sapphire radeon hd 4670 - Need Help!!!!!!!!!! Graphic Cards
Windows 7 Professional Won't Detect My Radeon HD 4670 Graphic Cards
Radeon 4670 trouble Graphic Cards
nvidia geforce 9800 gtx+ vs. ati radeon hd 4670 Graphic Cards
ATI Radeon 4670 Display Port Problem Graphic Cards
Radeon 4670 device trouble Hardware & Devices
ATI Mobility Radeon 4670 & Intel Confliction Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:22 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33