Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 7100 keeps losing my WD 1TB Green HDD

16 May 2009   #1

win xp
7100 keeps losing my WD 1TB Green HDD

Every so often my WD 1TB Green HDD disappears from the other drives. I have three hard drives in total attached to the computer besides the OS drive and only the WD disappears. It comes back sometimes if I put it to sleep and wake it back up.

Anyone know what's going on? Is it the low power state of the drive or what?

BTW I'm running 7100 x64

My System SpecsSystem Spec

16 May 2009   #2

Win 7 ultimate ver 7100 MSDN

Mine did this, I installed the tools for the drive and it stopped doing it
My System SpecsSystem Spec
17 May 2009   #3
Captain Zero

Windows 7 Home Premium x64

It sounds like it's powering down. Either check your power profile or, like monza says, download the 'tools' for it.
My System SpecsSystem Spec

17 May 2009   #4

7600.20510 x86

If you go to the device manager, click on anything at all, then at top action | scan for hardware changes, does it make the drive show up again in explorer (Computer.)

I know it's not THE fix for this, but I had an old cheapo 20 GB EIDE drive this exact thing was happening to. Disappearing in 7 (others not tested) even while copying from it to another drive or network drive. So instead of fussing with it or trying to repair with any tools, I just canned it.

Hopefully your 1TB behaves better for you though after doing what monza and Captain Zero are saying. Perhaps there is a firmware update or something, if not? I never did that to a HDD, so I dunno. Good luck!
My System SpecsSystem Spec
20 May 2009   #5

win xp

I tried going to the device manager and scanning but it didn't help.

I did however change the power settings to not go to sleep until two hours of innactivity and the drive has not disappeared since. The weird thing was though that the drive always disappeared while I was actively using the computer.
My System SpecsSystem Spec
20 May 2009   #6


oh, man, I remember this happening to Vista users too - I'll check to see if there was another fix posted or not....
My System SpecsSystem Spec
20 May 2009   #7

win xp

Quote   Quote: Originally Posted by johngalt View Post
oh, man, I remember this happening to Vista users too - I'll check to see if there was another fix posted or not....
It happened to me with Vista also but I eventually gave up on Vista due to that and a host of other reasons.

Windows 7 is mostly trouble free except for this.
My System SpecsSystem Spec

 7100 keeps losing my WD 1TB Green HDD

Thread Tools

Similar help and support threads
Thread Forum
Computer randomly turns off with green blinking green light on power
So today I was just watching a YouTube video, not gaming, not doing anything too intensive. Suddenly my computer shuts off with the power button blinking green. No BSOD, just powered off and won't turn back on. I tried unplugging the power cable and holding down the power button for 30 secs with no...
Hardware & Devices
Green screen when using VGA
When viewing the screen when using a VGA connection the entire screen has a green tint. I've borrowed another cable from a mate of mine an it didn't have the tint. Is there a way I can fix the cable so it wasn't green? Thanks
Music, Pictures & Video
My screen...its all green..idk how...
Okay, When I just turned on my computer 10 mins ago, and everything, and i mean everything, was green. I tried restarting it like 4 times and the issue has not been resolved. Im looking for a HP laptop now, but please tell me there's a fix to this!
Graphic Cards
green file
According to the user accounts, I AM an administrator. I, somehow, ended up with certain files that appear green in the Explorer and are unable to be copied to another directory, claiming to require an administrator. They are NOT read-only, but have an 'e' under attributes. What does that mean?...
General Discussion
Green 500 GB
Hallo out there, I'm concerned about a harddrive of mine which is a WD green. It has been making a strange sound when booting up and when I try to access data on it,, I'm on my knees with this one, because i've had another WD green which suddenly broke down without any notice... I've also had...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:14.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App