Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ACPI Device Windows 7

10 Sep 2010   #1
davpet

Windows 7 SP1
 
 
ACPI Device Windows 7

Greetings.

I would really appreciate having some further understanding on this.

I am running windows 7 on my Toshiba Laptop Model No: L300 PSL B9E.

If I take a look in my Device Manager I have two devices listed as other devices that are not installed. They are as follows.

ACPI\TOS1900 and ACPI\TOS1901.

My question is what are these two devices and their function and is it necessary for me to have these two devices installed.

Many thanks
Dave


My System SpecsSystem Spec
10 Sep 2010   #2
Lemur

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

It's a drive controller. Go to Toshiba support and download drivers.
My System SpecsSystem Spec
10 Sep 2010   #3
Lemur

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

AND
The 1901 is the Intel chipset. Recommended to go to Intel for this driver. See thread below:
Toshiba Support Forums: Unknown device ACPI\TOS1901 in Vista on ...
My System SpecsSystem Spec
10 Sep 2010   #4
richc46

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Do you have a Toshiba?
My System SpecsSystem Spec
10 Sep 2010   #5
Lemur

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

Quote   Quote: Originally Posted by richc46 View Post
Do you have a Toshiba?
Rich, I guess that question was to me? I have dealt with notebooks of all sorts, including Toshiba. I believe this is a European model, though for some reason I couldn't find the exact model on Toshiba's European site.
**EDIT** I have a graveyard of notebooks in my offices.
My System SpecsSystem Spec
10 Sep 2010   #6
richc46

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Question was not to you. We answered at the same time. Actually you answered twice to my once.
My System SpecsSystem Spec
10 Sep 2010   #7
Lemur

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

Quote   Quote: Originally Posted by richc46 View Post
Question was not to you. We answered at the same time. Actually you answered twice to my once.
LOL
My System SpecsSystem Spec
01 Sep 2013   #8
fits79

win7
 
 

Does anyone know from where i can download the "tos1901" drivers for toshiba satellite a210-19c and win7 home premium 64bit.
My System SpecsSystem Spec
Reply

 ACPI Device Windows 7




Thread Tools





Similar help and support threads
Thread Forum
Stuck on Starting Windows screen + XP only installs with non-ACPI
So my PC crashes the other day, and I figure its just one of those routine crashes. I reboot the machine but on loading it gets stuck on the 'Starting Windows' screen (The one where the four colored balls join to form the Windows logo). I try to run Start-up recovery from the Win7 cd and once again...
Installation & Setup
ACPI Windows update
i have win 7 64x ,i installed updates,before SP1,all are success, unless update for explorer 8,I think its because i update browswer to internet explorer 9,and main problem is acpi utility...this is main question,..why update didnt install acpi utility,how to see if its already in system?
Drivers
Strange Battery issue...looks Windows 7's Acpi
Hi there, since this morning i don't have anymore the icone & power management for my battery. The battery works fine when i unplug and let it for an hour, charging when plugin back. I looked everywhere and all seems correct. In Device Manager i uninstalled the Battery drivers, then rebooted...
Hardware & Devices
Windows XP - BAD_POOL_HEADER on acpi.sys Error
I am trying to install Windows XP SP3 on my HP Mini 1000 netbook from a USB thumbdrive. I am able to boot into Windows setup but I get a BSOD at the "setup is starting Windows" step. BAD_POOL_HEADER ... ***STOP: 0x00000019 (0x00000020, 0xF8471538, 0xF8471B50, 0xCCC35D5B)
Installation & Setup
ACPI Problems upgrading to windows 7
Hi there, I've got the following config: CPU P4 2.4 MSI PM8M-VH Ati 9200 Seagate 1TB Hitachi 1TB
Installation & Setup
Unknow Device (ACPI) & ITM x64 Win 7
Hallo! Can't good English but... I have a Laptop Compal FL90. Win 7 x64 on it. I have a Unknow Device: Hardware Ids ACPI/CPI0002. And Intel Turbo Memory --> I can't Enable ReadyBoost. Ready Drive is Enable. Can someone help me??
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App