Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Need to reinsert RAM

03 Oct 2010   #1

Windows 7 Ultimate 64 Bit
Need to reinsert RAM

I am totally getting confused. Last night there were 0 errors on Memtest and today in just 20 seconds there were 55 errors. I removed the RAM and re inserted and it was again fine with 0 errors. When i keep the ram installed for some time (usually 7-8 hours) it will start getting errors and BSODs and Memtest errors. When I remove and re insert it is fine.

Motherboard- Gigabyte ex58-extreme
CPU- Core i7 920
RAM- Corsair DDR3 2GB x 3
Corsair SSD

My System SpecsSystem Spec
03 Oct 2010   #2
Carl Lawrence

Dual-boot: Windows 7 HP 32-bit SP1 & Windows XP Pro 32-bit SP2.

It could be faulty.
My System SpecsSystem Spec
03 Oct 2010   #3

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Yes, as LW7 says, don't ignore a failed Memtest. You've got a RAM problem.

But don't read too much into the "reinsert RAM" thing. I think it is safe to assume that you are not doing this with the computer running! So you are shutting down, disconnecting power, and re-seating the RAM. That could simply mean that when you "cold boot" afterward you don't get any errors, but after it has been running a while the errors show up. That makes sense because when you cold boot all the RAM registers are "clean".

You can further test the RAM by installing one stick in slot A1 and running Memtest on it. Do the same for the other two sticks. If one stick shows errors and the others don't then you have your answer.

You can also try going into the BIOS and changing the Dram Frequency to 800 MHz as a test. Sometimes bad RAM will run fine at a lower frequency.

Keep in mind that the errors can also be caused by a faulty motherboard (RAM slot), power supply, or overheating. But most times it is just bad RAM.
My System SpecsSystem Spec

03 Oct 2010   #4

Windows 7 Ultimate 64 Bit

Everything is random. If it shows errors it shows on all RAM sticks and all slots. But when I remove and re insert then for next 5-6 hours it wont show any errors.
My System SpecsSystem Spec
03 Oct 2010   #5

MS Windows 7 Ultimate SP1 64-bit

replace the ram.
My System SpecsSystem Spec
03 Oct 2010   #6

Windows 7 Ultimate 64 Bit

the person from whom i bought RAM asks me to send the stick that is bad. He says all cannot be bad.
My System SpecsSystem Spec
03 Oct 2010   #7

Windows 7 Home Premium 64bit

While it is not likely that each and every one are bad, it is certainly possibile.
They cant simply just assume its not possible to happen.

Did you try TVeblen's advice?

Start in DIMM slot one and test each stick individully, and then to next slot?

If they all Fail in DIMM slot 1, but all pass in DIMM slot 2, its possibly a MOBO problem.

If some pass and the same ones fail regardless where they are its most likely a bad RAM module/modules.

If they all Fail regardless of location, it could likely be a MOBO issue, or all the RAM modules themselves are bad.
Although Ill agree all the modules being bad isnt likely, as I said earlier, it certainly is possible.
If this is the case, and you still have a warranty, I would make them replace the RAM.

Just out of curiosity, would you mind posting a snip of the CPUZ screen for the Memory TABs?
Just to rule out settings if anything else.
My System SpecsSystem Spec

 Need to reinsert RAM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
SD Card does not mount after reinsert
I did a search but it didn't turn up anything so I'm hoping someone here can help. My SDHC (4GB) card is read fine and mounted correctly when I boot Windows with the card in. However if I remove it (always safely!) then insert it back I hear the sound from Windows as if it recognizes a new device...
Hardware & Devices
how to reinsert (reintegrate) a WinMail and Gadgets platform
Hi, can you, please, post how to reinsert (reintegrate) a WinMail and Gadgets platform in already installed OS Win 7 which is "lited" (with removed this features?) :o THX! ;)
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:26.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App