Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird Win7 issue


15 Oct 2010   #1

Windows 7 Home Premium 64bit
 
 
Weird Win7 issue

I have a 2.5" 160GB drive which I can place in my external eSATA dock and Windows 7 finds it and adds it, I need to run FAT32 on it so create for example a 10gb partition and format it FAT32 within Windows 7, I've also tried 3rd party apps that make the partition 160GB and format it FAT32 it makes no odds which method.

The problem is I copy files to it etc and it doesn't complain. Remove disk, re insert it later on and everything on it will have vanished like I never did it, it does seem I can create a folder and it will stay there, the files I've tried copying are not large, at most 40mb.

If I repeat the same but with NTFS it's fine and files stay so what's going on?
If I mount the disk on the iPad which is what I intended to use it for it recognises it and I can copy files from the system to the HDD and they show up in Windows 7 just not when I do it in Windows 7.

What's going on?

My System SpecsSystem Spec
.

18 Oct 2010   #2

Windows 7 Home Premium 64bit
 
 

No one?
My System SpecsSystem Spec
19 Oct 2010   #3

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

When you "remove" the eSATA drive, are you just unplugging it? Or are you going through "safe removal" first?

I'm guessing the first, which if that is true, means that you have buffered writes that have not yet finished when you unplug the drive.

But, if you're doing the second, I don't know what the problem could be as that is supposed to ensure that all buffered writes complete before it tells you it's OK to remove the drive.
My System SpecsSystem Spec
.


19 Oct 2010   #4

Windows 7 Home Premium 64bit
 
 

How long does it leave them in the buffer then?
I've left it 10 minutes before with the same result but I can't see a way of removing the drive besides pulling it out of the dock or powering the dock off. It doesn't get a 'safely remove hardware' option like USB devices.
My System SpecsSystem Spec
20 Oct 2010   #5

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

Having not even been able to get eSata to work on my box, I would have to guess that there would an icon in the notification box you would click, like the USB icon, to then safely remove the drive.
My System SpecsSystem Spec
20 Oct 2010   #6

Windows 7 Home Premium 64bit
 
 

Nope no icon like with USB devices, it would be a bit like ejecting your C: drive
My System SpecsSystem Spec
Reply

 Weird Win7 issue




Thread Tools



Similar help and support threads for2: Weird Win7 issue
Thread Forum
Weird Issue Network & Sharing
A very weird activation issue Windows Updates & Activation
Have a weird issue. Win7, Windows 2003 Server, some shares missing Network & Sharing
Weird graphics issue Gaming
Weird issue? Performance & Maintenance
Weird printer sharing issue - XP and Win7 Network & Sharing
Weird Issue Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:30 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33