Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 64bit 4gb installed 3.12 usable?


03 Jun 2009   #1

W7 64b - Leopard 10.6.2 - Ubuntu 10.10 (MBP Snow Leopard 10.6.3)
 
 
64bit 4gb installed 3.12 usable?

Hi all,

I have Windows 7 installed with 4gb, but only 3.12 is usable.

How come? Any ideas out there?


My System SpecsSystem Spec
.

03 Jun 2009   #2
Microsoft MVP

Win 7 Ultimate x64
 
 

Without knowing your system specs can't point you in the right direction, but check in the bios for a setting having to do with memory remapping. Depending on the motherboard and/or who built the computer, it may not be there and if it isn't then you're stuck with what is available unless there is a bios update that will allow the option.

More info here,

http://support.microsoft.com/kb/929605

Quote:
The BIOS must support the memory remapping feature. The memory remapping feature allows for the segment of system memory that was previously overwritten by the Peripheral Component Interconnect (PCI) configuration space to be remapped above the 4 GB address line. This feature must be enabled in the BIOS configuration utility on the computer. View your computer product documentation for instructions that explain how to enable this feature. Many consumer-oriented computers may not support the memory remapping feature. No standard terminology is used in documentation or in BIOS configuration utilities for this feature. Therefore, you may have to read the descriptions of the various BIOS configuration settings that are available to determine whether any of the settings enable the memory remapping feature.
My System SpecsSystem Spec
03 Jun 2009   #3

Win 8 Release candidate 8400
 
 
32 ram limit

boris
I think you prob have a 32 bit system and maybe even shared video. the max a 32 bit can "see" is abt 3.5 gig and hware may even eat a little bit more. Mine does.
My System SpecsSystem Spec
.


04 Jun 2009   #4

Windows 7 Ultimate 64 BITS
 
 

My System SpecsSystem Spec
04 Jun 2009   #5

W7 64b - Leopard 10.6.2 - Ubuntu 10.10 (MBP Snow Leopard 10.6.3)
 
 

Ah, thx for the info i will investigate. Sorry for the repost.
My System SpecsSystem Spec
11 Dec 2009   #6

windows 7 64-bit
 
 
try this

i had the same problem. In the morning i had 4gb of ram installed and working by evening only 3 working (4 showing). Now i had installed updates earlier today so i thought that might have something to do with it. i tried a few solutions on here nothing worked for me. i checked bios, it was fine. when I restarted my pc msn started so i went into msconfig to switch it off in startup(type msconfig into run) out of curiosity i clicked on boot-> advanced options and for some reason the box maximum memory was checked. so i unchecked it and restarted and now i have 4gbs again. I think one of the security updates must've have ticked the box. But try this anyway, i hope it works for you
My System SpecsSystem Spec
11 Dec 2009   #7

Windows 7 Ultimate 64 BITS
 
 

i change my mobo and now im using 8gb instead of 4 with no problems
i guess i was having that memo limit because of chipset
anyway
thx all
My System SpecsSystem Spec
13 May 2010   #8

Windows Server 2010 Ultimate Workstation RC1
 
 
This solution worked for me

Quote   Quote: Originally Posted by Ealezy1992 View Post
i had the same problem. In the morning i had 4gb of ram installed and working by evening only 3 working (4 showing). Now i had installed updates earlier today so i thought that might have something to do with it. i tried a few solutions on here nothing worked for me. i checked bios, it was fine. when I restarted my pc msn started so i went into msconfig to switch it off in startup(type msconfig into run) out of curiosity i clicked on boot-> advanced options and for some reason the box maximum memory was checked. so i unchecked it and restarted and now i have 4gbs again. I think one of the security updates must've have ticked the box. But try this anyway, i hope it works for you
THIS WORKED FOR ME! Thanks!

I have 12GB and Windows 7 x64 Ultimate was only showing 10GB usable. I unchecked that box in msconfig and restarted the computer, and now it's back to normal (All 12GB of RAM is available now). Thanks again!
My System SpecsSystem Spec
Reply

 64bit 4gb installed 3.12 usable?




Thread Tools



Similar help and support threads for2: 64bit 4gb installed 3.12 usable?
Thread Forum
4gb of RAM installed, but w7 says 256 usable Performance & Maintenance
64bit win7 4gb installed, 1.7gb usable Hardware & Devices
Installed vs Usable Ram Performance & Maintenance
Windows 7 64bit shows 3.73GB usable memory with 8GB installed Performance & Maintenance
Solved RAM: 4GB installed and only 2.93 usable. Hardware & Devices
Solved 6 GB Installed (3 GB usable) Hardware & Devices
4G memory installed 2G usable 64bit system Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:50 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33