Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Creative Zen Mozaic

27 Oct 2010   #1

Windows 7 Home Premium 32bit
 
 
Creative Zen Mozaic

Can't seem to get my Zen mozaic to work althou it says it is compatible here
Windows 7 Compatibility for Creative Zen Mozaic 4GB Black Media Player: Creative. Drivers, Updates, Downloads

When I plug it in it keeps saying device failed to install. Upon looking in device manager it says

"This device is not configured correctly. (Code 1)

The system cannot find the file specified.


To find a driver for this device, click Update Driver."

But when I try to update driver it still doesn't fix it saying

"Windows found driver software for your device but encountered an error while attempting to install it.
MTP USB Device
The system cannot find the file specified"

Device properties now saying
"The drivers for this device are not installed. (Code 28)"

Can anyone give some advice I heard windows 7 had issues with mtp devices but idk what to do to fix this.

My System SpecsSystem Spec
.

27 Oct 2010   #2

Windows 7 x64 Home Edition
 
 

Hello Keke
Have you been pushing windows 7 updates lately? I know sometimes when this happens to me I do a reboot and it usually works afterwards but sometimes its a persistent little bugger and requires a little more than a reboot, Do you have another computer you could possibly test this on? To see if it is the device or your computer?
My System SpecsSystem Spec
28 Oct 2010   #3

Windows 7 Home Premium 32bit
 
 

I download windows updates pretty frequently. I only just recieved my mp3 player 3 days ago, bought it off amazon but it hasn't installed or appeared under my computer on my laptop. I have tried it on my bf's computer he has windows xp and it worked fine I didn't even have to install firmware or creative centrale it just appeared under my computer so I was able to add music that way but when it comes to my laptop it hates me lol. I won't always be able to go to his house to put music on my player thou that's why I've been trying like crazy to figure this out. I've uninstalled and reinstalled in device manager even did it in safe mode and nothing. But it does charge when plugged into mine.
My System SpecsSystem Spec
.


29 Oct 2010   #4

Windows 7 x64 Home Edition
 
 

If you have libusb-win32 exe process running, it will block you're Vision:M from being recognized by the computer. You can do a couple of things to solve the problem. Either go into task manager and stop the process, or go into control pannel (classic view)> administrative tools> services and stop the process from there.

Or

1. Plug the Zen in to the PC
2. Hold the power button 'on'
3. Press Reset twice
4. (This takes some time to load, about 30-45 minutes) But when it does you should get a list of options, select Reboot.
5. Hey presto, computer recognises Zen.
My System SpecsSystem Spec
29 Oct 2010   #5

Windows 7 Home Premium 32bit
 
 

Idk if libusb-win32 exe blocks all players but I have a Zen Mozaic not a Vision:M in any case thou I couldn't find libusb-win32 exe in the task manager or in services. . When I tried what you mentioned to do nothing happened it started as normal. So I went to reboot the only way I know how by going into recovery mode like this

Turn off player.
Press and hold the Play/Pause. Continue to hold the Play/Pause button until you perform Steps 3 and 4.If you accidentally release the button, start the procedure again.
Gently push the end of a thin object (like a pin or straightened paperclip) into the Reset hole. The reset button for the ZEN Mozaic is located on the left side of the player, with the menu buttons facing you.
Slide the On/Off/Lock switch towards the power button and hold until the display lights up. The Recovery Mode screen appears, and four menu items are shown: Clean Up, Format All, Reload Firmware and Reboot.

and rebooted while plugged in and nothing it still has an exclamation point in device manager with code 28 displayed in the properties.
My System SpecsSystem Spec
29 Oct 2010   #6

Windows 7 x64 Home Edition
 
 

My System SpecsSystem Spec
30 Oct 2010   #7

Windows 7 Home Premium 32bit
 
 

Unfortunately for me I've actually already tried the stuff on that link that is actually the same link that creative sent to me when I emailed them. However I tried it again idk if I'm doing something wrong or what but it says in that link for code 28

Code 28 Recommended resolution

Install the driver
You may be prompted to provide the path of the driver. Windows may have the driver built-in. If you are asked for the driver and you do not have it, you can try to download the latest driver from the hardware vendor’s Web site.
In the device Properties dialog box, click the Driver tab, and then click Update Driver to start the Hardware Update Wizard. Follow the instructions to install the driver.

After trying to update again it said "Windows encountered a problem installing the driver for your software." "MTP Usb Device, the system cannot find the file specified"

I'm at a loss I don't know what to do. Based on what I read about that message on microsoft answers it recommended doing a repair install of windows 7 with a link to this site on repair installs and even thats not working either my install hangs while checking compatibility.



After trying to update a couple different things in device manager it would seem lots of files can't be found automatically. I don't know if that makes a difference or not however when I chose to to update from a specific location it usually works just not when I try to do it with the Mozaic.
My System SpecsSystem Spec
01 Nov 2010   #8

Windows 7 Home Premium 32bit
 
 

So again creative replied back after me telling them yet again I can't update my driver for my Mozaic and told me to reinstall wmp 12. How in the world do they expect any one to reinstall something that is built in. Does any one have any suggestions on how I can fix this because I can't even repair install windows 7. This is so frustrating I'm actually considering buying a msc mp3 player.
My System SpecsSystem Spec
01 Nov 2010   #9

Windows 7 x64 Home Edition
 
 

I know that this is probably really frustrating for you, I know that I had purchased a Zen about 4 years ago and I absolutely hated it.

(Credit to Mckillwashere)
Try this for WMP12
go into add remove programs, click on add windows features. and find it in that list uncheck. apply reboot repeat and check. reboot
Control Pannel >> Programs and Features >> Turn Windows Features on or off >> Media Features >> Windows Media Player
http://www.sevenforums.com/attachments/installation-setup/99121d1285018761t-help-repairing-capture.jpg


My System SpecsSystem Spec
02 Nov 2010   #10

Windows 7 Home Premium 32bit
 
 

Sadly for me that didn't work in fixing the problem I guess I will start looking for a new player. I found this list of creative players that are msc Creative Worldwide Support been thinking about the zen MX or possibly a sony msc player. Any thoughts or suggestions on what I should go with considering my problem with mtp players?
My System SpecsSystem Spec
Reply

 Creative Zen Mozaic





Thread Tools



Similar help and support threads for2: Creative Zen Mozaic
Thread Forum
CREATIVE XFI SB 0460 do not run with WIN 7 64 Sound & Audio
Creative Audigy 5.1 Sound & Audio
creative nx pro. help a girl out.. Drivers
Creative X-Fi Xtremegamer Sound & Audio
creative x-fi Sound & Audio
Creative SoundBlaster 5.1 Sound & Audio
Creative X-Fi WDM Drivers Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:51 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33