Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 did not install my extra Maxtor HD


10 Jun 2009   #1
BEe

windows 7
 
 
Windows 7 did not install my extra Maxtor HD

Hi all

I have just installed windows 7, and it seems to run very well, however it cant find my second harddisk.

My harddisk is a 500 GB Maxtor, with an TX2Plus controller on the motherboard - when I look up the device in the device manager, it is missing a driver for a "Mass Storrage Controller".

I have searched the web, but cant seem to find any drivers.

Any help will be great

Best regards
Jens

My System SpecsSystem Spec
.

13 Jun 2009   #2

Windows 7 Enterprise x64 SP1
 
 

My System SpecsSystem Spec
14 Jun 2009   #3

Windows 7 RC
 
 

You might also try going into "Administrative tools...Create and format hard disk partitions" and see if it shows up there.

If it does and it does not have a drive letter, give it one.

It worked for me. I had a conflict with drive letters.

Your mileage may vary
My System SpecsSystem Spec
.


15 Jun 2009   #4
BEe

windows 7
 
 

Hey

I found the drivers for the card, and it works now - thanks for the help

I now have another problem, from time to time I loose my internet connection - and after 5-10 restarts, it returns. I have 6-7 computers in my LAN, and it's the only computer that looses the internetconnection.

Any idears to what the problem might by? and how to solve it?

Best regards
Jens
My System SpecsSystem Spec
15 Jun 2009   #5

Win 8 Release candidate 8400
 
 

BEe
First welcome to sevenforums.
We could help you more if you filloed in "my system specs" in control panel. Are all comuters running win 7, are you using a homegroup, etc. Info please

Ken
My System SpecsSystem Spec
30 Jun 2009   #6

Windows 7
 
 
Maxtor OneTouch III

Hello everyone,

I am new here and recently install Windows 7. I love it and everything runs great, except for my external Maxtor. I installed the Vista drivers like I thought I was supposed to do but the program won't load, and the computer doesn't recognize the drive at all. Hopefully there are some alternate drivers but any help would be much appreciated. Thanks !
My System SpecsSystem Spec
30 Jun 2009   #7

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

When you say it is not recognised - do you mean in Disk Management?


Some USB ports don't provide enough power to power up the drive (the drive will usually blink or make a beep sound if it doesn't have enough power). Be sure to use a USB port on the back of the computer. If your computer doesn't supply enough power a powered USB hub can help.
My System SpecsSystem Spec
30 Jun 2009   #8

Windows 7
 
 

it is not recognised in disk management or in the computer at all

I know it has enough power and it works fine because I used it several days ago before I install Windows 7, unless having Windows 7 makes it run weird, but that wouldn't make sense to me
My System SpecsSystem Spec
13 Dec 2009   #9

Windows 7
 
 

Quote   Quote: Originally Posted by BEe View Post
Hey

I found the drivers for the card, and it works now - thanks for the help

I now have another problem, from time to time I loose my internet connection - and after 5-10 restarts, it returns. I have 6-7 computers in my LAN, and it's the only computer that looses the internetconnection.

Any idears to what the problem might by? and how to solve it?

Best regards
Jens
can u tell me which of the cards did u use for the driver download..
My System SpecsSystem Spec
15 Mar 2010   #10

Windows 7
 
 

Hello to everyone, please apologize for my english.
Well, the problem is:
When I plug the Maxtor Basic Desktop HD to my computer it displays the hard drive like a local disk and says that if I want to use it, I'll have to format.

If I try to do that it says that the HD have 43.5 GB of capacity instead 1 TB and says that it's not possible to format; then it advise me to check if the hard drive is plugged correctly and if it's on "only read".

If I refuse to format another error window appears, this one says that the volume doesn't contain a valid file system and asks me to check that the driver are all ok.
Just for additional information, this hard drive works perfectly on vista and on windows seven all the other HD works correctly.

Thanks for the help.
Virgil
My System SpecsSystem Spec
Reply

 Windows 7 did not install my extra Maxtor HD




Thread Tools



Similar help and support threads for2: Windows 7 did not install my extra Maxtor HD
Thread Forum
Extra System drive created during install, how to delete? Installation & Setup
extra files (on D drive) after Visual C++ 2010 Express install? Software
i have an extra vid card, can i install it ? Graphic Cards
Windows 7 and extra 12 GB upon install General Discussion
Maxtor 1TB External HDD issue in Windows 7 Hardware & Devices
trying to install 7 on IDE Maxtor drive NTFS formatted Installation & Setup
Maxtor Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33