Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Not all USB ports are working

15 Dec 2010   #1

Dual-boot: Windows 7 HP 32-bit SP1 & Windows XP Pro 32-bit SP2.
 
 
Not all USB ports are working

Hello guys,

I have just got my motherboard replaced by a PC World Techguy and I got it back last week. Because the BIOS on the new motherboard has not be altered to the same has the old one. The front 2 usb ports are not being recongized, but the one that my usb hub is plugged into is working OK. Am I missing a setting in Bios or something?

My System SpecsSystem Spec
.

15 Dec 2010   #2

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

Mate, I think you just got a bad MoBo....
My System SpecsSystem Spec
15 Dec 2010   #3

Windows 7 Home Premium 64bit
 
 

Carl,
See if this link helps any or the Bios may need to be reset. Wait for more help on the Bios as I'm not qualified to advise you.


Device Manager - Finding Unknown Devices
My System SpecsSystem Spec
.


15 Dec 2010   #4

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

Foxconn - Products: Motherboard This is your motherboard correct?

The front usb's are normally connected via a cable to the motherboard. Is this cable plugged into the right spot?
My System SpecsSystem Spec
15 Dec 2010   #5

Dual-boot: Windows 7 HP 32-bit SP1 & Windows XP Pro 32-bit SP2.
 
 

I think it might be a bios setting, because there is one on the back that is below my usb hub plug, which did not like my mouse.
My System SpecsSystem Spec
15 Dec 2010   #6

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

I have noticed on several on the pcs I work on there are 2 boot device (Keyboard/mouse) ports on most pcs. If i did not have my mouse and keyboard plugged into them they would not function until they were plugged into the proper ports.
My System SpecsSystem Spec
15 Dec 2010   #7

Windows 8 Professional
 
 

i think mckill had it right in his first post. Have you inspected the mobo for the add-on usb connections?
My System SpecsSystem Spec
15 Dec 2010   #8

Dual-boot: Windows 7 HP 32-bit SP1 & Windows XP Pro 32-bit SP2.
 
 

Perhaps that is what could be, but it does not really matter as I have spare ports on my hub.
My System SpecsSystem Spec
Reply

 Not all USB ports are working





Thread Tools



Similar help and support threads for2: Not all USB ports are working
Thread Forum
Solved USB ports not working Hardware & Devices
2 out of 3 USB Ports not working Drivers
Solved Front USB ports not working, but rear USB ports work… Hardware & Devices
USB ports are not working Hardware & Devices
none of my USB ports are working Hardware & Devices
USB ports not working...PLEASE help! Hardware & Devices
USB ports not working Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:38 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33