Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HELP


29 Dec 2010   #1

Windows 7 Home Premium 64-bit SP1
 
 
HELP

My second HDD, which is my 149GB disk seems to have failed. I know it is working due to the reason it is warm to the touch and has that very small vibration all PATA disks have. It was working yesterday but today the desktop icon has a ? mark by it, it wont show-up in "My Computer" and Speccy can't find it neither, any way to recover my beloved files, or get the disk working again?

UPDATE:
It's okay now, I took out the cables and plugged them back in, so maybe it was loose, when I get a new rig I'll need help setting up a RAID though since this experience made me fear for my files.

My System SpecsSystem Spec
.

29 Dec 2010   #2

Windows 8.1 Pro
 
 

If I were you, I'd start backing my my files off that drive.... just in case
My System SpecsSystem Spec
29 Dec 2010   #3

 
 

Quote   Quote: Originally Posted by sygnus21 View Post
If I were you, I'd start backing my my files off that drive.... just in case
My System SpecsSystem Spec
.


Reply

 HELP




Thread Tools



Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:58 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33