Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External Drives disappeared ?

31 Dec 2010   #1
Marlbo

Windows 7 Ultimate x64
 
 
External Drives disappeared ?

Hi,

Hope some-one can help ?
I bought 2 external USB connected hard drives approx 6 months ago, they were permanently connected and turned on, working fine and showing as drives I & J on my PC.
They are different models but yesterday both suddenly decided to disappear from my PC ?
Even the desktop shortcut Icon to an application on one of the drives has reverted to that familiar Icon denoting the absence of an application/file.
The only unusual thing I have done recently is upgrade my Internet Security system to the 2011 version a couple of days ago.
Apart from the obvious turning the external drives off then back on, I have absolutely no idea what I can do to get these back so any tips would be very much appreciated !

Thanks in advance.....?

Marlbo


My System SpecsSystem Spec
.
31 Dec 2010   #2
Marlbo

Windows 7 Ultimate x64
 
 

In case anyone's interested should they have the same problem I have just found my own answer....
Just completed a System Restore to the time before I upgraded my Internet Security system and the missing drives have now re-appeared so looks like it's my Security system messing things up which shouldn't surprise me, it has a good reputation but is rubbish to use !
I would have expected problems if I was changing my Security but I was only upgrading.

Thanks.....

Marlbo
My System SpecsSystem Spec
31 Dec 2010   #3
rvbfan

Windows 7 Home Premium 64bit
 
 

Seems to be a more and more common problem these days. First thing I check
when family members have problems with connectivity.


Thanks for posting your resolution.
My System SpecsSystem Spec
.

Reply

 External Drives disappeared ?




Thread Tools




Similar help and support threads
Thread Forum
All Flash Drives & External Hard Drives NOT ACCESSIBLE?
I set up a new computer. Windows 7 Pro 64x Everything was fine but then I connected a flash drive to it and I get: Location Not Available H:\ is not accessible. Access is denied If I go into the properties to the “security” tab, it says “you do not have permission to view or edit this...
Hardware & Devices
External USB2 drives "disappeared" from the computer explorer window
I have four external usb drives. All seem to have disappeared at the same time. I checked one of them on another computer and it's fine. There's no error \ in the device manager, except it said that the device on one port had failed. I disabled that but left it plugged in because I don't know...
Hardware & Devices
SATA drives : internal appear as External drives !
Hi very bizarre : - 3 of my 6 drives SATA connected to internal SATA connectors on board ( Z87 Deluxe) - are shown in explorer "my computer" as hard disks ( while correctly DVD and USB are in removable drives list) - however these 3 drives appear in the list of removable drives Under the W7...
Hardware & Devices
2 Disk Drives Disappeared
Hello, Recently I found that my disk drives - B: and Z: have disappeared. B: used to have torrent downloads and other data, while Z mostly had media files. And data WAS important. I have had 4 partitions, C(OS drive), K(has all kind of data), B and Z. I'll list down recent activities...
General Discussion
One of my hard drives have disappeared from the system
Yesterday I installed a new SSD and re-installed my OS and a bunch of non-game programs onto it, then formatted my 500GB WD HDD which used to hold the OS and all programs and games, while leaving my remaining 250 WD HDD untouched as it had file backups and media on it. All the controllers are...
Hardware & Devices
Optical drives have disappeared
My two optical drives have disappeared. I've searhed this and other forums for solutions and the ones that are Wizards from MS can't seem to find anything wrong. I'm pretty sure this has happened after a big string of Win 7 updates or some other software update I can't remember. Any thoughts other...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App