Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Logitech Driving Force EX - Force Feedback Motor Query


21 Jan 2011   #1

 
Logitech Driving Force EX - Force Feedback Motor Query

So... Before anyone tells me to send it to Logitech for repairs, I should mention that there are none that I know of in my area, and I'm not willing to pay R300 (ZAR) postage to send a big box 600km away to get my wheel 'checked'. Other than that, it's already nearly 3 years old and way out of warranty...

Now, onto the finer details. The force feedback suddenly stopped working one day a few months back. There was no funny smell or smoke or unusual amount of heat, etc.. Anyways, long story short: I suspect the motor is the culprit here, I can't see any damage or burn marks on the IC boards..

A Google search for the details on the side of the motor returns nothing even remotely related to Logitech or electronics in general, so I'm hoping someone can help point me in the right direction here.

Markings on the side:
RS-545PH-12320
* Made in China
TD417427
50.0V

The * above is a symbol, almost like a logo, but I don't recognise it... I've redrawn it in Paint (see attached), perhaps someone else knows it...? Other than that, I've also attached a photo of the motor with a CD beneath it for a size reference.

I don't play racing games enough to warrant buying a new wheel, and everything else on the wheel still works, I simply don't have any force feedback and the wheel obviously doesn't center itself anymore (no springs, all done with the motor). If anybody can help point me in the right direction with looking for a way to either test / repair / replace this motor, I would be eternally grateful...


PS: I am currently trying to sort out my account on the Logitech forum to ask there as well, but seeing as I haven't used my account in about 2 years (problems with an old MX1000), it's been disabled, I can't 'enable' my account, and it won't let me register again...



Attached Thumbnails
Logitech Driving Force EX - Force Feedback Motor Query-imag0058.jpg  
Attached Images
 
My System SpecsSystem Spec
.

29 Nov 2013   #2

Windows 7 Ultimate x64
 
 

Hello, I am also facing the same problem as faced by you. The wheel is working fine but there is no ff. I dont know whether the fault lies with adapter or with motor or it is a circuit problem. Could you please tell me how did you manage to solve your problem??
My System SpecsSystem Spec
Reply

 Logitech Driving Force EX - Force Feedback Motor Query




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:16 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33