Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External hardrive not "loading".

24 Jan 2011   #1
Skulblaka

Windows 8 Professional 64-bit
 
 
External hardrive not "loading".

Greeting everyone,

I ran into a problem again, it's my external 2TB hard drive. Yesterday it worked fine. Now, I connect my hard drive, then I go to "My Computer", the window is blank, it's loading... for a while, most of the time Windows becomes unresponsive, I'm starting to get a "little" frustrated. All of my programs become unresponsive and I have to end them. I received an error earlier, I'll try to recreate it.

I cannot access my external hard drive. It's a "Seagate Free Agent." The data on it is crucial, I cannot lose any of it, 1TB of data!

If you need more things about this situation, please ask.


My System SpecsSystem Spec
.
24 Jan 2011   #2
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

Hello there, Skul!

Are you connecting the HDD to the same USB port as always?

Have you tried accessing the HDD in Safe Mode? There's no need to panic, i know your data is important and let's try to solve the issue
My System SpecsSystem Spec
24 Jan 2011   #3
Skulblaka

Windows 8 Professional 64-bit
 
 

Quote   Quote: Originally Posted by Punkster View Post
Hello there, Skul!

Are you connecting the HDD to the same USB port as always?

Have you tried accessing the HDD in Safe Mode? There's no need to panic, i know your data is important and let's try to solve the issue
Thanks for your quick response, I like your avatar by the way, I'm not panicking. Heheh, "Don't Panic!". Anyway, I'll try you suggestion.

Also, it's the same USB port as always, also, the external drive isn't making the "usual" clicking sound when I access it. I hear the disks spin up, but no major clicking... strange.
My System SpecsSystem Spec
.

24 Jan 2011   #4
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

Hehe thanks in the worst case you could just try to access it via Ubuntu Live CD, also.. could you check the HDD in Device Manager? to see if something unusual comes up

Did you install any programs since yesterday when the HDD was working?
My System SpecsSystem Spec
24 Jan 2011   #5
Skulblaka

Windows 8 Professional 64-bit
 
 

I tried safe mode, same thing, no luck. No new programs installed, the last task I was performing was a defrag which I stopped later on when I came home. The program was TuneUp Utilities, a trustworthy application. Nothing is unusual with the Device Manager.

Huh, the system confirms there is a device connected. "Safely Remove Hardware and Eject Media" shows up, when right clicking it shows the hardware that I try to access, my external drive.
My System SpecsSystem Spec
24 Jan 2011   #6
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

Waaaaaaaaaaaaaaaaaaaaait i usually don't trust TuneUp Utilities, i said that to another guy on the forums and you'll find here a lot of member who share the same feelings...

Were you defragging the HDD with TuneUp??
My System SpecsSystem Spec
24 Jan 2011   #7
Skulblaka

Windows 8 Professional 64-bit
 
 

Quote   Quote: Originally Posted by Punkster View Post
Waaaaaaaaaaaaaaaaaaaaait i usually don't trust TuneUp Utilities, i said that to another guy on the forums and you'll find here a lot of member who share the same feelings...

Were you defragging the HDD with TuneUp??
Yes, but I don't see much of a problem, I had done it multiple times with no problems.

I don't see the problem with defragging. Besides, I've used TuneUp for quite a while.
My System SpecsSystem Spec
24 Jan 2011   #8
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

Nono, defragging it's OK it's just that i don't like TuneUp Utilities at all hehe but hey! it works for some, it doesn't for some...

Any news yet? have you been able to access the HDD?
My System SpecsSystem Spec
24 Jan 2011   #9
Skulblaka

Windows 8 Professional 64-bit
 
 

I haven't been able to access it, I fear the worst. I have two possible ways, one I will try right now, try to access through Ubuntu and/or from an other computer. The last option is to try use some sort of software to try to salvage what I can if at all possible.

I'll still try to take suggestions or ideas on what I can do, any help will be appreciated.

--- EDIT ---

Well, I really need this explained. Right now I'm on Disk Management, look at the image included, I need to know what that means, there should be 980GB free from this external hard drive (F).

This possibly means... I've lost... about four months of work... this isn't happening.


Attached Thumbnails
-capture.jpg  
My System SpecsSystem Spec
24 Jan 2011   #10
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

Wait, why is there a "RAW" partition on the 2TB drive, and why is it empty?! now that's scary...

Boot from a Ubuntu Live CD and try to access the HDD.. that'd be my last option
My System SpecsSystem Spec
Reply

 External hardrive not "loading".




Thread Tools




Similar help and support threads
Thread Forum
WD EXTERNAL HARD DISK 1TB suddenly "unallocated" and "not initialized"
Hi guys. I'm new here. I've tried to read all the discussion about how to fix the unallocated hard drive but I just can't understand it as the cases were pretty much different than I'm facing of. Here's my problem. Yesterday my external hard drive seems normal, everything is fine, until...
Hardware & Devices
external hardrive error loading WA.FAT32
i have my external hard drive last time is good but now i cant open it it says like this ERROR LOADING WA.FAT32 THE SPECIFIED MODULE CANNOT BE FOUND. please help me
Hardware & Devices
External hard drive "hanging" or infinite loading.
So I have a pretty, well not old, but it's not a product they carry anymore external hard drive and I had some issues with it in the past (mainly the usb port not being soldered on properly and falling off); so I just received all my replacement cords for it and ran it, it took *forever* for it to...
Hardware & Devices
Both "System reserved" and "C" partition cloned to external HDD: boot?
With EaseUS Backup Tool, I've cloned these two partitions ("System Reserved" and "C") to same-sized partitions on a external HDD ("X" and "Y"). Picture tells it concisely: How to make drives "X" and "Y" boot-able? In "Disk Management", I've noticed these partition labels missing: "X" (or...
Installation & Setup
Seagate FA GoFlex Desk external hardrive doesn't show in "My Computer"
I reimaged my computer because I was having a whole bunch of trubble with it (no of which really matter now). After reimaging I tried to access some of the files I saved on my external hard drive, but no matter what I tried I could not get access to the files. The drive appears in device...
Drivers
Windows 7 32 bit, when loading "Open With: ?" "File: Media" comes up
Hello there, when the desktop loads up, I get this strange message: "Open With: Choose the program you want to use to open this file: File: Media" http://i54.tinypic.com/6rtxlu.jpg
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:36.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App