Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cataclysm MMO mouse causing crashes

26 Jan 2011   #1

Windows 7 64bit
 
 
Cataclysm MMO mouse causing crashes

Hello, I'm running Windows 7 64bit on an asus essentio CG 1330 and I recent bought the World of Warcraft: Cataclysm gaming mouse from Steelseries. At first I was able to plug it in and use it, but when I tried to install the software it would complete and I would get a message that the "firmware number on your mouse is 125, would you like to upgrade to 131?" If I clicked no, the update would not go through.

If I clicked yes, it would freeze my computer, than blue screen and crash. I tried re-downloading the software and it did the same thing. Now I can't even plug the mouse in without getting a bluescreen and my computer crashing. I realize that this is most likely the device and not Windows fault, but if anyone could explain to me why this is happening I would be very grateful.


My System SpecsSystem Spec
.

26 Jan 2011   #2

Windows 7 Professional x64
 
 

I'm not so go with this, but have you tried other ports?
My System SpecsSystem Spec
26 Jan 2011   #3

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Welcome to Seven Forums.

First off I'm assuming you have a laptop when I respond with this method.
Un-install the driver and if you have any software associated with it use Ccleaner under tools then software
CCleaner - Download it's a great program to have anyway.

Now unplug your laptop>remove the battery for around 5 minutes. This should re-set the CMOS. Setting everything back to default.
Try re-installing the original driver/software that worked.

If you have a desktop download the manual and find out how to reset the CMOS. You can also achieve this by removing the battery but it's usually easier to just change a jumper on the motherboard.
Then follow the above again and see if it will allow you to re-install the working driver/software.
Fabe
My System SpecsSystem Spec
.


27 Jan 2011   #4

Windows 7 64bit
 
 

Thanks for the responses, but I think I may have just recieved a faulty mouse, because now it has completely stopped working. I'll just send it back for a replacement and see if that fixes things.
My System SpecsSystem Spec
Reply

 Cataclysm MMO mouse causing crashes




Thread Tools



Similar help and support threads for2: Cataclysm MMO mouse causing crashes
Thread Forum
Logitech mouse causing system to become unresponsive Hardware & Devices
Solved BSOD Causing Mouse To Malfunction! Hardware & Devices
Hard disc causing crashes? Browsers & Mail
Mouse movement causing jerky video in IE9 Browsers & Mail
winlogon causing my usb mouse to hang startup..help General Discussion
Micro. Sec. Ess. Causing Crashes? System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:50 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33