Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mouse problems in Windows 7 (64-bit)


22 Jun 2009   #1

Windows 7 64-Bot
 
 
Mouse problems in Windows 7 (64-bit)

I run Windows 7 on two of machines. One runs flawlessly. The other ran flawlessly for about a month or two, and then I started getting a rather odd problem. The OS fails to recognize my (mostly) left mouse clicks for random periods of time, say 5 seconds to like 60 seconds. It'll work, then it'll stop, then it'll work... etc. Obviously this is extremely frustrating. Thinking it's the mouse, I tried another mouse - same problem.

Both mice are USB, but it does not seem to be an issue with the USB ports as my keyboard and other USB peripherals work fine.

Running the C2D Extreme Quad core from a couple of years ago, X38 chipset board, 4870x2.

I'm baffled on this one, hopefully someone out there has an idea. Oh, I formatted and reinstalled the first time this problem came up, and it started again within a few hours of the reinstall. All I've got installed besides my drivers are:

Firefox
AIM
ATI Catalyst Control Panel


My System SpecsSystem Spec
.

23 Jun 2009   #2

Windows 7 64-Bot
 
 

As an update, i've discovered that it's more you can't left click "in" anything. Like, I can right click the desktop, and left click will work in the context menu.. but if i click out of that and try to click on the start button or whatever, it doesn't work.
My System SpecsSystem Spec
25 Jun 2009   #3

Windows 7 RC
 
 

What mouse are you running? I have a Logitech MX6100 that seems to have the similar issues. I couldn't drag and drop, it would open the file all the time. I did find I could right click and move the file or icon but then it asked if I wanted to move the file....too many clicks just to move a screen icon.

Logitech doesn't seem concerned that their drivers don't work with Windows 7. I went back to my Microsoft corded IntelliMouse

I really miss my 6100.
My System SpecsSystem Spec
.


25 Jun 2009   #4

Windows 7 64-Bot
 
 

My main mouse is a G7, the wired one i tried was some old USB logitech one.
My System SpecsSystem Spec
04 Jul 2009   #5

Windows 7 7264 x64
 
 

Same problem for me with win 7 7264 x64 and Logitech G5...
I have to do CTRL+ALT+CANC, click one time, so returning on the desktop, mouse works....(!!)

It's a bug

All right with Win 7 7229 x64...
My System SpecsSystem Spec
04 Jul 2009   #6

Win 8 Release candidate 8400
 
 
mouse prob

Quote   Quote: Originally Posted by Kemortia View Post
I run Windows 7 on two of machines. One runs flawlessly. The other ran flawlessly for about a month or two, and then I started getting a rather odd problem. The OS fails to recognize my (mostly) left mouse clicks for random periods of time, say 5 seconds to like 60 seconds. It'll work, then it'll stop, then it'll work... etc. Obviously this is extremely frustrating. Thinking it's the mouse, I tried another mouse - same problem.

Both mice are USB, but it does not seem to be an issue with the USB ports as my keyboard and other USB peripherals work fine.

Running the C2D Extreme Quad core from a couple of years ago, X38 chipset board, 4870x2.

I'm baffled on this one, hopefully someone out there has an idea. Oh, I formatted and reinstalled the first time this problem came up, and it started again within a few hours of the reinstall. All I've got installed besides my drivers are:

Firefox
AIM
ATI Catalyst Control Panel
I had a similar problem w mice and keyboard. I changed them out and prob remained. I went into device manager and found two unknown devices in usb section. Could you check that section and see if anything looks amiss. Upload a snip would help

Ken
My System SpecsSystem Spec
04 Jul 2009   #7

Windows 7 7264 x64
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
I had a similar problem w mice and keyboard. I changed them out and prob remained. I went into device manager and found two unknown devices in usb section. Could you check that section and see if anything looks amiss. Upload a snip would help

Ken

My devices are ok...



Now same problem with 7229...
My System SpecsSystem Spec
04 Jul 2009   #8

Win 8 Release candidate 8400
 
 

my apologies but the snips are so small I cant read them. could you try again

Ken
My System SpecsSystem Spec
04 Jul 2009   #9

Win 7
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
my apologies but the snips are so small I cant read them. could you try again

Ken
Here you can use my magnifying glass.

My System SpecsSystem Spec
05 Jul 2009   #10

Windows 7 7264 x64
 
 

Image isn't important... All my devices are installed correctly... I don't understand..

I dont want to come back to Vista...!!!
My System SpecsSystem Spec
Reply

 Mouse problems in Windows 7 (64-bit)




Thread Tools



Similar help and support threads for2: Mouse problems in Windows 7 (64-bit)
Thread Forum
Mouse problems Hardware & Devices
Help with mouse problems General Discussion
Solved Mouse problems Hardware & Devices
Mouse Problems Hardware & Devices
Mouse Problems General Discussion
usb to ps2 problems with mouse Hardware & Devices
VX revolution mouse problems. Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:39 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33