Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't print: just says "Error - Printing" in queue


09 Feb 2011   #1

Windows 7 Home Premium 64bit
 
 
Can't print: just says "Error - Printing" in queue

This is a new laptop, Windows 7 Home Premium 64 bit, and I have installed drivers for both my HP Laserjet CP1215 and Canon MP150 (and re-installed quite a few times now too...).

Whenever I try and print a document, from WordPad, Adobe Reader, Word, whatever, it just appears in the print queue with the Status as "Error - Printing".

If I run the HP diagnostics utility, it can print test pages, no problem. So the USB connection and actual printer are fine. They also work fine with other PCs.

I've checked the print spooler is up and running in "Services".

Exactly the same problem happens with both HP and Canon printers (both are USB).

Anyone please help!


My System SpecsSystem Spec
.

09 Feb 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Hello Parrotx34. Welcome to the Forum.

When you go to Start > Devices & Printers > right click the printer and select Printer Properties , Can you print a Test Page?

In the same window, under the Ports Tab, what port does it show each printer connected to?
My System SpecsSystem Spec
09 Feb 2011   #3

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Try clearing the print spool.

How to clear the print spool
My System SpecsSystem Spec
.


09 Feb 2011   #4

Windows 7 Home Premium 64bit
 
 

Thanks for the replies!

- Using the Properties -> Print test page, same result, gets errored document in queue [it was the test page via the HP diag util that worked earlier]
- It is connected to USB001 "Virtual printer port for USB"
(I have also tried a different USB port, same result - my other printer is also connected to USB002, same problem there).

Re: the spool, I've checked and C:\Windows\System32\spool\PRINTERS is empty (unless I have not deleted the failed printing attempt, in which case there are a couple of files in there).

The PC has also been through multiple reboots as I re-re-installed drivers etc..

Anything else I can look at?
My System SpecsSystem Spec
09 Feb 2011   #5

Windows 7 Home Premium 64bit
 
 

Maybe its not related, but I just tried:

Devices and Printers -> Properties -> Advanced -> "Print directly to printer" -> Apply

I got an error box: "Printer settings could not be saved. Operation could not be completed (error 0x0000070c)."
My System SpecsSystem Spec
03 Apr 2011   #6

Windows 7 Home Premium 64bit
 
 

I found a solution for the ASUS G73 printing problem: Install the latest Fresco USB3.0 driver.

Here is the ASUS forum thread with the info.

I'm pretty sure I posted my solution here too. Wonder where it went?
My System SpecsSystem Spec
12 Aug 2012   #7

Windows 7 Ultimate 64 bit
 
 

Hi,
I have just an hour or two ago posted a very similar problem Windows 7 Ultimate, with the HP G55 printer. I have not tried updating the USB drivers (using another USB port as they may not all be the same is another solution I have heard of elsewhere).

I get partial print jobs, some or rarely all the job prints.

A crazy but possible solution is to start the two Bluetooth services, this appeared to work initially for me.
Don't worry that you may not have Bluetooth on the PC or any Bluetooth devices even if you have.

Regards.....
My System SpecsSystem Spec
13 Dec 2012   #8

windows 7 ultimate x64
 
 

I have found the solution!!!!

When downloading recent versions of Adobe Reader, there is a checkbox that must be unchecked, otherwise McAfee Security Scan Plus will also be downloaded and installed.

Go into Control Panel --> Programs and Whatever; then uninstall McAfee Security Scan Plus. Restart your PC. Problem solved.

/me shakes fist @ McAfee
My System SpecsSystem Spec
20 Dec 2012   #9

Windows 7 64bit
 
 

Just registered here so I could thank parrotx34 for providing me with an answer to MY question! Have been trawling the net all day looking for a resolution to fixing "printer spooler" error message I kept getting when trying to install compatible driver for Canon Pixma MP150 so it would work on Win 7 64bit. Not ONE expert on the web mentioned the small fact that you should check in an area called "Services" to make sure the Printer Spooler was 'started'. Not everyone would be aware of that. Fixed it right up. So thanks for your remark about this parrotx34! I owe you one
My System SpecsSystem Spec
30 Jul 2014   #10

win 7 64bit
 
 
Printers showing an error message

Hi,

My printers kept on showing an error message and would not print.

Go into: Control Panel > Hardware & Sound > Devices and Printers >

Choose the relevant printer by right clicking on it.

Go to Printer Properties.

Choose Ports

Choose the correct port for e.g. mine were on LPT 1 but my printers are connected via USB - so choose the USB001, USB002, etc port by ticking on the box by the side of the port.

Hopefully this works for others as well.
My System SpecsSystem Spec
Reply

 Can't print: just says "Error - Printing" in queue




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:11 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33