Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No boot after ram upgrade


26 Jun 2009   #1
Shader

Linux Mint 7
 
 
[Solved] No boot after ram upgrade

Hello I have 2GB (1GBx2) ram on my pc and have dual-boot Windows 7 and Ubuntu Server 8.04. Today i've upgraded my ram to 3GB. I added one more 1GB ram. When I tryed to boot after placing the ram, the Windows won't boot. The bios and the GRUB boot loader runs okay, I could even boot the Ubuntu Server 8.04 with no problem and saw that there is 3 Gigs of ram. When I try to boot into Windows 7, I get a black screen and my keyboards and mouses lights are turned off. I guess there's a problem with recognizing new hardware. I left the pc for 10 minutes to wait it to recognize but it made no change. I removed the new ram and now I'm able to boot into Windows 7. What should I do to boot Windows 7 RC with 3GB of ram?

Thanks


My System SpecsSystem Spec
26 Jun 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 
boot prob

Quote   Quote: Originally Posted by Shader View Post
Hello I have 2GB (1GBx2) ram on my pc and have dual-boot Windows 7 and Ubuntu Server 8.04. Today i've upgraded my ram to 3GB. I added one more 1GB ram. When I tryed to boot after placing the ram, the Windows won't boot. The bios and the GRUB boot loader runs okay, I could even boot the Ubuntu Server 8.04 with no problem and saw that there is 3 Gigs of ram. When I try to boot into Windows 7, I get a black screen and my keyboards and mouses lights are turned off. I guess there's a problem with recognizing new hardware. I left the pc for 10 minutes to wait it to recognize but it made no change. I removed the new ram and now I'm able to boot into Windows 7. What should I do to boot Windows 7 RC with 3GB of ram?

Thanks
Hi and welcome to SF
Since you're able to get into bios does it recognise the 3 gigs?
Ken
My System SpecsSystem Spec
26 Jun 2009   #3
DarkXeno

Windows 7 Ultimate x64 SP1
 
 

Welome zigzag3143 to SF.

Try to remove the ram and boot into windows then with 2 gigs again. If that works then make sure you do a full shutdown on windows do not suspend or hibernate the machine, that is when I have seen this problem is when people hibernate it then do a ram upgrade since that is just a save state it can confuse windows and cause it not to boot.
The other thing you can try is to reset you bios to the defaults and boot into windows.
Let us know if this helps you.
My System SpecsSystem Spec
26 Jun 2009   #4
Shader

Linux Mint 7
 
 

I mentioned that it worked when I removed the ram. ATM I'm on the same pc with 2GB ram. But I didn't try the BIOS thing, I'll try it later and bump the thread when I do in a hour or so thx for the advice

Edit: Okay I managed to boot somehow. I didn't change anything in bios, just entered setup and discarded changes. It booted okay. Don't know what happened, maybe just luck. Thanks.
My System SpecsSystem Spec
Reply

 No boot after ram upgrade




Thread Tools



Similar help and support threads for2: No boot after ram upgrade
Thread Forum
Upgrade RAM from 4 to 16 GB, W7 won't boot; Ubuntu will Hardware & Devices
BCD error trying to boot from upgrade DVD Installation & Setup
Win 7 upgrade iso will not boot Installation & Setup
W7-64 UpGrade won't boot from DVD Installation & Setup
Dual boot with upgrade Win 7 from XP Installation & Setup
Cannot boot upgrade CD Installation & Setup
Upgrade Boot Disk General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:03 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App