Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: DG35EC Windows 7 Slow When Using 8gb of Ram

25 Feb 2011   #1

Windows 7 64bit
DG35EC Windows 7 Slow When Using 8gb of Ram


I installed Windows 64 with 4gb of ram and everything works fine, but when I tried to install 4 more gb of ram the system boots very slow or hangs. The bios is updated and the 8gb appears to be working fine in the bios. Something else I notice is that if I boot in the "SAFEMODE" the system will hang at 'CLASSPNP.SYS" Nevertheless when I remove the extra Ram all these symptoms will go away. Additionally I have tried switching the ram to make sure I didn't have any bad ram chips, but it doesn't matter which set of ram chips I use as long as I don't go over 4 gb.

I have checked around and several including Microsoft insist that I need to go into the BIOS and enable the "memory remapping" feature, but I can't find this setting anywhere in the BIOS.

In summary

DG35EC will work great with 4 gigs, but if I add another 4 gb the system runs very slow. I do want to note that I do have two different brands: 4gb 6400 Samsong + 4gb 6400 Hynix.


My System SpecsSystem Spec
25 Feb 2011   #2

Windows 7 Home Premium 64 bit

Is the RAM timing and other specs the same?
My System SpecsSystem Spec
07 Mar 2011   #3

Windows 7 Ultimate x64

I had the same problem. The 0118 version of the BIOS is the cause of this error. Update the BIOS to version 0116 and problem solved! Here is the link of the BIOS driver (0116 version):

I hope this help.
My System SpecsSystem Spec

01 Oct 2012   #4

Windows 7 Pro 64bit

I had the same issue. After increasing the RAM from 4gb to 8gb, Win7 64bit slowed way down, both in startup time and functionality. This is a multi-boot system and interestingly the Win7 32bit did not slow down when the additional RAM. The BIOS downgrade/update to 0116 fixed my identical issue. I had actually gone from 0117 to 0118 attempting to address the slowdown, but the 0116 was the fix. With the 8gb RAM and the BIOS at 0116 Win7 64bit now boots to the desktop in 40 seconds - the same as it did with 4gb of RAM; when I had increased the RAM from 4gb to 8gb it had jumped to taking over 3 minutes to get to the desktop when the BIOS was at 0117 and 0118.
My System SpecsSystem Spec

 DG35EC Windows 7 Slow When Using 8gb of Ram

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Windows boots very slow and runs slow after booting
Hello 7forums. I have a problem with my Windows 7 Professional (32bit). I'll try to explain everything in detail. Yesterday I was using uTorrent to download some files (24 gigabytes +). It was downloading at a speed of ~7-8 Mb/s. During the download I noticed that the PC was running pretty...
Performance & Maintenance
Slow boot, followed by crash and reset. Very slow repair center load
Running Win7x86, and it started getting extremely slow, within 2 days of this it started refusing to load at all. The system is brand new (ready built from ebuyer), and the only alterations have been a sysfan, spare hdd, spare dvdrw. When trying to load the boot screens take AGES, often...
General Discussion
Slow start-up; crawls into BIOS setup; then slow to load windows
Hi there, please can you help? I realize this BSOD might be a commonly reported problem but the issues here seem not to have been addressed specifically by other threads so I hope I haven't opened a new thread unnecessarily. Anyhow, here goes...:) Various pc problems have arisen since coming...
BSOD Help and Support
Which graphics card suitable for INTEL DG35EC
HI ppl, Im using intel DG35EC mother board with windows 7 OS. I already search for graphics card suitable for my board, as a result i desired Nvidia GeFore 9800 GT. But when i ask for this card in shop they told It's stopped selling and they said it's old model. I don't know which...
Graphic Cards
Windows 7 slow startup slow everything hp mini 1035nr
Hi i have installed windows 7 ultimate on my hp mini 1035nr running atom n270 processor and it is very very slow the startup takes atleast 9 minutes but when i take out the wifif it goes down to a minute so its driver problems also and while im in windows i cant open anything its all laggy choppy...
General Discussion
Slow to open apps, all Net apps slow, slow to type... laggy everything
I have a nearly fresh install of Win7 32 bit on a pretty modern machine. It has been intermittently laggy since I installed Win7 about three weeks ago. Here is a list of symptoms: 1) Apps are slow to open 2) Double clicks aren't registered until 5-10 seconds later 3) Typing is slow on most...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:27.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App