Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Intel i series (i3,i5,i7) usb Root hub problems

25 Feb 2011   #1

windows 7 64 bit home
Intel i series (i3,i5,i7) usb Root hub problems

Hi ive got a Sony vaio f series Intel i7 laptop running windows 7 64bit home premium.
Ive encountered a lot of problems with usb 1.0 devices, Microsoft and Intel are aware of the problems but they still aren’t fixed. First I have had alot of issues with rane scratch live SL1, which is a usb 1.1 device, ive managed to get that working now, mainly down to service pack 1. Im still finding though that i cant seem to use two usb devices at the same time? All i want to be able to do is use a usb mouse and or scratch live or a external sound card. Whichever usb device i plug in 1st is the one that works, but i can’t use both at the same time, which is so frustrating! Has anyone else had this problem and can anyone help me?

Heres some examples of what the usb problem is if i havet explained very well....

Connectivity of USB 1.1 devices on non-root hubs .: Focusrite Answerbase

Quad-Core Issues? [Intel Core i-series] |

My System SpecsSystem Spec
19 Apr 2011   #2

Windows 7 Home Premium 64bits

It's a common problem for Vaio's... Power supply is not able to "feed" all the USB ports and they become locked by the system. Try the following:

- Shut it down completely.
- Unplug everything.
- Remove the battery for 10-15 seconds.
- Plug everything back
- Start it!

I'm sure it will work ;-)
My System SpecsSystem Spec

 Intel i series (i3,i5,i7) usb Root hub problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
USB port not working Intel USB3 xhci Driver for Intel® 8/9 Series
Hi, Just wondering if anyone has been having the same issue. Windows 7 x64 series 8 motherboard. ASUS z87-expert. My USB3 and USB2 are not working right after I install the Intel USB3 xhci Driver for Intel® 8/9 Series version I have used the setup.exe to install the driver...
Intel USB 3.0 root hub and USB root hub registries missing/incomplete?
Ok, so I've run into a very tricky spot: Yesterday, I successfully resolved a windows update issue (thread can be found here: ). Basically, one problem led to another and I ended up...
Tons of problems with USB Root Hub
Okay, I'm new to this forum so if I do anything incorrectly I'm quite sorry :p I've recently had tons of problems with my USB Root Hub. I was getting some BSOD's (not the issue), and I found that my usb root hub had an exclamation point in device manager. Okay, good, cool, no more bsod's....
Hardware & Devices
Intel Confirms Bug in 320 Series SSD
Read more at: Maximum PC | Intel Confirms Bug in 320 Series SSD
Hardware & Devices
The Intel i series
How can you tell how much GHz a system has when you are taking a look at specs of an advertised system? I can't quite make up that part when I look at the numbers that accompany the i series processors. now I udnerstand all i7s are quad(are they?) but some i5s are quad and some are not... how do...
Hardware & Devices
Intel Core i7 Series
Hey guys, I was recently researching new computer parts and stuff for my computer, as it is really crappy, and I am considering the new Core i7. I was wondering if a) this CPU was any good, and b) if it would do well when running 7 with it. As well, I am posting this to create a discussion...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:53.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App