Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Stumped - Add Device or Remove Device Not Working

12 Mar 2011   #1

7 Premium X64
 
 
Stumped - Add Device or Remove Device Not Working

HI

I have searched high and low for a resolution.

OK.
When I went to add a new Bluetooth keyboard (Control Panel>Add Devices).
When pressing Add Device, nothing happens.

I have two Bluetooth devices already installed, are listed under "Devices" are "found" and work fine.

Problem is that, I can not either add new devices or, remove any of my Bluetooth devices already installed.
Click Add Printer - fine, the wizard starts.
Add Device - nothing.

"Remove Device" - when a device is highlighted for removal, the system appears to be "working" for a moment, but then does not remove the device, it remains.


Have checked that Services related to Bluetooth have not been disabled but am wondering if anyone knows if there are any specific services that would be required for Add Devices or Removal of Devices to function? (HID Devices and Plug and Play are Started / Automatic)

Thanks for any help.

My System SpecsSystem Spec
.

12 Mar 2011   #2

Windows 7 Ultimate 32bit
 
 

Just a blind shot. Try MS Solution Center Microsoft Fix it Solution Center: troubleshooting software issues . In the "Select problem area" choose " Install or Upgrade Software or Hardware" and click on " Run Now - Hardware devices are not working or are not detected in Windows". Do report whether it resolved your problem or not.
My System SpecsSystem Spec
12 Mar 2011   #3

7 Premium X64
 
 

Thanks for the reply -
Will go and check now.

Forgot to add that, prior to the reported problem, I had installed a new hard drive using a complete image from another drive.
Dont see what that would change but worth adding.
My System SpecsSystem Spec
.


12 Mar 2011   #4

7 Premium X64
 
 

HI again.

When I got there and got to the
" fit it" .exe,I recognized it and have tried it.
I get an error, "The Command Line Argument is Invalid" when prog starts to run.



error code: 0x80004003

Looks like a reinstall of Windows is in my future.

What keeps puzzle'n me is that the problem appears isolated to only "Add Device or Remove Device" starting and that the currently installed devices are working fine and can be turned off and on..

Well, thanks for the lead.
Will update if solution is found.
My System SpecsSystem Spec
25 Mar 2012   #5

windows 7 home premium
 
 

I also have the same problem.Currently installed devices are working fine but not able to add any new bluetooth devices.Please let me know if you found any solutions.
My System SpecsSystem Spec
Reply

 Stumped - Add Device or Remove Device Not Working




Thread Tools



Similar help and support threads for2: Stumped - Add Device or Remove Device Not Working
Thread Forum
Remove Unspecified Device Hardware & Devices
Solved Device manager does not detect sound card. Experienced builder stumped Hardware & Devices
Safely remove usb device General Discussion
Solved Remove device showing in MyComputer Hardware & Devices
How do I get Stereo mix working when usb device is default device? Sound & Audio
Can't safely remove device Hardware & Devices
can not remove device from device manager Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:35 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33