Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Ever had a problem connecting 2 "identical" external HDDs?

27 Mar 2011   #1
mjf

Windows 7x64 Home Premium SP1
 
 
Ever had a problem connecting 2 "identical" external HDDs?

If you have ever connected 2 identical ext HDDs and found both work fine independently but not when both plugged in.
Then you may have this unusual problem I just struck.
Bought WD Elements 500GB as a present 3 months ago.
Bought another on special recently.

Whenever one is plugged in first works fine. Second one is not assigned a letter and offline. Reverse the disks and the same applies.

Both where manufactured with the same disk signature!!!!
Changing the disk signature of one solved the problem.


My System SpecsSystem Spec
.

27 Mar 2011   #2
bones1

win 7Professional 64
 
 

Possible driver signature problem. Look in storage devices for an error, maybe
My System SpecsSystem Spec
27 Mar 2011   #3
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Interesting, mj.

Windows is supposed to do that for you.

Perhaps it doesn't if they are both usb connected.
My System SpecsSystem Spec
.


27 Mar 2011   #4
mjf

Windows 7x64 Home Premium SP1
 
 

Quote   Quote: Originally Posted by SIW2 View Post
Interesting, mj.

Windows is supposed to do that for you.

Perhaps it doesn't if they are both usb connected.
Yes that also puzzled me about Windows not automatically changing one.

It was a long shot - I looked at the MBR of the disks with a Hex editor and couldn't believe it.

What about the poor soul that just wants to plug them in and work!
My System SpecsSystem Spec
Reply

 Ever had a problem connecting 2 "identical" external HDDs?




Thread Tools





Similar help and support threads
Thread Forum
WD EXTERNAL HARD DISK 1TB suddenly "unallocated" and "not initialized"
Hi guys. I'm new here. I've tried to read all the discussion about how to fix the unallocated hard drive but I just can't understand it as the cases were pretty much different than I'm facing of. Here's my problem. Yesterday my external hard drive seems normal, everything is fine, until...
Hardware & Devices
Need to add "TASKBARS" (MSese for "Launchpads", "Docks" NOT "Toolbars"
My office just upgraded, and I can no longer use Windows XP. On this system, I was able to add a separate taskbar to facilitate quick access to commonly-browsed folder locations on our vast network, and another one expedited the launching of useful programs and lists. Each task on each taskbar...
General Discussion
Sony Vaio Laptop "stopped" connecting to WiFi connection " Limited acc
Hi, I am hoping you can help me with my problem. My main laptop (Sony Vaio VPCCB15FG) in the last week just stopped accessing the internet via WiFi. It says it has Limited Acess but I have no idea how to fix it. The other 3 computers in the house (Custom desktop, Toshiba Net book, Samsung...
Network & Sharing
Both "System reserved" and "C" partition cloned to external HDD: boot?
With EaseUS Backup Tool, I've cloned these two partitions ("System Reserved" and "C") to same-sized partitions on a external HDD ("X" and "Y"). Picture tells it concisely: How to make drives "X" and "Y" boot-able? In "Disk Management", I've noticed these partition labels missing: "X" (or...
Installation & Setup
Windows keeps "losing" secondary HDDs
Having a bit of an issue. First off. System is stock. I haven't OC'd anything yet. AHCI mode. SSD boot drive in SATA0, data drive(s)s in SATA1, DVD drive SATA2. Gigabyte z68ma-D2H-B3 i5 2500k (stock until this is figured out) 2x2Gb G.Skill 1600 Antec Basiq 430W No extra GPU, stock Intel...
Hardware & Devices
2.5" External drive "falls asleep"?!?!
So I've been up for hours this morning, fighting with a brand new Seagate 500Gb Extension 2.5" portable hard drive. While transferring 120Gb of information from the drive to an internal drive, it often stops copying/moving halfway through. It seems to happen mostly on large (1Gb+ files), but has...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App