Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 does not detect second hard drive in new Asus G73JW laptop


06 Apr 2011   #1

Windows 7 (Home Premium 64 bit and Pro 64 bit)
 
 
Windows 7 does not detect second hard drive in new Asus G73JW laptop

Hi, I just bought an Asus G73JW. I also picked up two new SSD's (Kingston SNVP325-128G), removed the two 500Gb OEM drives from the G73JW and tried to do a clean install on these new drives. I'm having some problems recognizing the second drive and I hope there is help for me.

On the first drive, I've installed Windows 7 Pro 64 bit, followed by Kubuntu 10.10. Everything works great in Kubuntu... I can see and use both drives without any problems (the first drive has an NTFS partition for Windows 7 and an EXT4 partition for Kubuntu). The second drive is just NTFS.

When I boot into Windows, the second drive is not detected anywhere. In particular, I open the Computer Management -> Disk Management tool, and it only shows the first hard drive (and it's partitions). There is no trace of the second drive, and rescanning for it doesn't find it.

So I thought, I should reboot, go into the BIOS, see if there's a problem. I tried this. The BIOS does not show the second drive either, even though Kubuntu has no problems at all reading and writing to the second drive. As best as I can tell, this has to do with the BIOS/motherboard treating the second drive as a slave drive.

So then I tried this: I removed the drive from the internal slot, connected it to an external drive bay (via USB). The drive shows up just fine, and both Windows and Kubuntu can read and write to the drive just fine. I reformatted the drive to NTFS from Windows, just to ensure that this wasn't the problem. Then I disconnected it from the external USB hookup, and put it back into the internal hard drive bay. Reboot into Windows. Nothing. Reboot into Kubuntu: it works just fine.

What gives? Does anyone have any experience with something like this? Very frustrating to think the only way I could get this second hard drive to work is by external USB.

Thanks in advance for any comments.

My System SpecsSystem Spec
.

Reply

 Windows 7 does not detect second hard drive in new Asus G73JW laptop




Thread Tools



Similar help and support threads for2: Windows 7 does not detect second hard drive in new Asus G73JW laptop
Thread Forum
Windows 7 installation doesn't detect hard drive Installation & Setup
windows 7 cant detect external hard drive Hardware & Devices
Solved Windows 7 (and BIOS) don't detect new hard drive Installation & Setup
Windows 7 64bit Asus G73jw Bsod BSOD Help and Support
Windows 7 Doesn't Detect My Hard Drive Installation & Setup
Windows 7 can't detect my external hard drive Hardware & Devices
Windows has detect failing hard drive BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:13 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33