Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Windows did not detect a properly installed network adapter

10 Apr 2011   #1

Windows 7 64bit
 
 
Windows did not detect a properly installed network adapter

Hello,

I'm having trouble accessing the internet on a new build.

My motherboard is Asus P8P67 Pro R3 P67 Socket 1155 8 Channel HD Audio.. | Ebuyer.com and I'm running Windows 64bit. My router is Linksys WRT54GS version 6.

When I diagnose the problem it tells me

"Windows did not detect a properly installed network adapter. If you have a network adapter, you will need to re-install the driver"

I have downloaded PC Wizard 2010 and under Network I get "Yes" and a green tick, but I get "No" and a red cross for Internet Connection and no further details.

When I click into Network, it shows:

Connection Type: Disabled

I don't know if this information is relevant?

When I go into Device Manager I can't see any Network Adapter, where should it appear?

Just to confirm, the router is working fine with Windows 7 on my other machine.

Can anyone offer any assistance please?

My System SpecsSystem Spec
.

10 Apr 2011   #2

Windows 7 Pro x64 SP1
 
 

It sounds like you don't have the correct driver for your network adapter. Can we assume that this is a network adapter on the motherboard? If so, then you might check in bios to see if it is activated.
Otherwise, there could be a conflict between some of the other devices you have in your machine.

Check bios first. (if it is on the motherboard) otherwise, if it is a board, plug into another slot and see whether it will discover the board.

Rich
My System SpecsSystem Spec
10 Apr 2011   #3

WIN7 Ultimate 64bit
 
 

Stick the asus dvd in,
computer management/update driver
point it at the dvd drive D: or E: whatever
My System SpecsSystem Spec
.


10 Apr 2011   #4

Windows 7 Pro x64
 
 

Really you need to load the drivers. Whether they are on the CD that came with the motherboard or you download them from the Asus website.
My System SpecsSystem Spec
11 Apr 2011   #5

Windows 7 64bit
 
 

Thanks guys.

Wasn't sure what a network adapter was and thought it was to do with the router.

Loading the drivers from the motherboard CD worked a treat, Peace.
My System SpecsSystem Spec
11 Apr 2011   #6

WIN7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by PerfectDark View Post
Thanks guys.

Wasn't sure what a network adapter was and thought it was to do with the router.

Loading the drivers from the motherboard CD worked a treat, Peace.
Glad you are sorted!
My System SpecsSystem Spec
Reply

 Windows did not detect a properly installed network adapter





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:01 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33