Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SSD not appearing in Computer


13 Apr 2011   #1

Windows 7 Pro 64
 
 
SSD not appearing in Computer

I've installed a new SSD as a secondary drive and it has worked for two days. At the moment, I can't see any mention of it in Computer (Windows Explorer) but the BIOS detects it.
There is a screenshot below of the disk manager, I believe Disk 2 should be the 120GB Intel X-25M G2 SSD:


Also, ignore the 8GB drive listed there, it's just a harmless USB.

How do I fix this? I don't have any data worth keeping on it so I'm quite happy to get a blowtorch and format the drive if needed.

My System SpecsSystem Spec
.

14 Apr 2011   #2

Windows 7 Home Premium 64bit
 
 

I'd recommend you boot into a Linux live cd and reformat the SSD. I would not recommend touching that disk 2 one unless you are certain it's the SSD.
My System SpecsSystem Spec
14 Apr 2011   #3

Windows 7 Home Premium x64
 
 

We need to see more of the graphical portion of the screen. It looks like there are a few more physical drives there, one or more likely shows as unallocated or not initialized, that's where your SSD would show if it's never been formatted.
My System SpecsSystem Spec
.


14 Apr 2011   #4

Windows 7 Pro 64
 
 

It was formatted and I used it for a bit until recently with this.
Here are some more pictures




After Hard Drive Diagnostics (SSD is in SATA 4, ignore the rest).


BIOS can't see SSD properly anymore.
My System SpecsSystem Spec
17 Apr 2011   #5

Windows 7 Pro 64
 
 

Any suggestions?
My System SpecsSystem Spec
17 Apr 2011   #6
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

See whether you can get it with elevated Command Prompt. use these commands each followed by Enter:

Diskpart
List disk
Select disk n (where n is the number that was given for your SSD in List disk)

Create partition primary align=1024
Active (assuming you want to install an OS)
Exit
My System SpecsSystem Spec
17 Apr 2011   #7

Windows 7 Pro 64
 
 

Didn't seem to detect the 120GB SSD:
My System SpecsSystem Spec
17 Apr 2011   #8
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

You are right. It seems to be AWOL. Did you try another port? Also, did you set the BIOS to AHCI?
My System SpecsSystem Spec
25 Apr 2011   #9

Windows 7 Pro 64
 
 

My motherboard doesn't support AHCI but I switched SATA ports and got the same messages D:
My System SpecsSystem Spec
Reply

 SSD not appearing in Computer




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:36 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33