Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Camera appears twice in autoplay

02 May 2011   #1
nate42nd

Windows 7 Professional x64
 
 
Camera appears twice in autoplay

I got a new camera and had to replace it because of a defect.....the exact same model. Now it appears twice in autoplay in the settings where you decide what you want Windows to do when media is connected.

Camera appears twice in autoplay-devicestage.jpg

I got a camera, plugged it in via USB, Windows got the driver on it's own, and I have no other problems. How do I delete one of the occurrences besides the registry? The registry may be the only way but if anyone can think of another way I cannot think of...let me know. These small things bug me when I cannot figure them out. Thanks




My System SpecsSystem Spec
.
02 May 2011   #2
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

They should be listed in Device Manager.
Maybe under Human Interface Devices.
If not under that heading it may have a separate one for cameras.

Win7 recognized each camera individually since serial # etc. are different.

If you find them in Device Manager right click each one and left click properties. Check the dates of install of driver. Newest date is newest camera. The oldest one just right click and click Uninstall in Device Manager.

Hope that helps. They should be listed somewhere in Device Manager

Mike
My System SpecsSystem Spec
03 May 2011   #3
nate42nd

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by Hopalong X View Post
They should be listed in Device Manager.
Maybe under Human Interface Devices.
If not under that heading it may have a separate one for cameras.

Win7 recognized each camera individually since serial # etc. are different.

If you find them in Device Manager right click each one and left click properties. Check the dates of install of driver. Newest date is newest camera. The oldest one just right click and click Uninstall in Device Manager.

Hope that helps. They should be listed somewhere in Device Manager

Mike
I checked the device manager but maybe the device needs to be connected at the time. Thanks for the info Mike. I will try that tomorrow.
My System SpecsSystem Spec
.

03 May 2011   #4
alphanumeric

Windows 10 Education 64 bit
 
 

While in device manager, select "show hidden devices" under the view tab. You might get lucky and have it show up then. The other place to look is the "Devices and Printers" screen.
My System SpecsSystem Spec
Reply

 Camera appears twice in autoplay




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Turn on autoplay for camera card insertion?
Dad just called and wants to know why his Fuji camera card isn't bringing up a box to import pictures when he plugs it into PC. I connected and sure enough the card is in Computer as a drive and readable, but apparently the autoplay setting has been lost after his printer was installed last week....
Hardware & Devices
Canon camera recognized on USB, but not AutoPlay
I have two HP laptops and a Canon SX130is digital camera. I am not using Canon's camera software -- I just want to download photos. Both computers are running Win7-64. Both are Home Premium Versions. On my HP Envy, USB recognizes, the camera, AutoPlay opens so I can select my action and I can...
Hardware & Devices
Portable devices not listed in Autoplay option . Won't pop autoplay.
Hi I have protable device that won't autoplay when plugged , but it is shown in my computer and it's fully functional , it is not visible in the Autoplay option in the control panel , I tried reinstalling the device , but same thing , I followed Shawn's topic , how to set autoplay for...
Hardware & Devices
Autoplay
Why do some devices (mainly external disc drives) automatically open autoplay whilst some I have to open "my computer" and select "open autoplay. And some automatically start playing my selected autoplay option! Annette
General Discussion
Win 7 won't autoplay my Sony camera
When I plug my USB Sony Cybershot camera in I don't get the autoplay option coming up, even though I have 'ask me every time' selected. I can see the camera in Explorer and can get to the pictures, but I woulld like to be asked if I want to download the pictures to a folder!
Hardware & Devices
Autoplay
I have an external USB 120GB 2.5" PATA HDD that I'm setting up to hold portable applications. I've gone to portableapps.com and downloaded theirv1.6 platform only. I've my own portable apps to run with the platform. One major problem is that I can't get it to auto run. I've tried...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App