Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Printer Problem


12 Jul 2009   #1

win7
 
 
Printer Problem

I have two printers, both about 3/4 years old. They both work great, and I use them a lot. And as I said I have 2 computers, my XP computer and my Win 7RC computer. I am using KVM switch, connecting the 2. They are connected to the XP computer with USB. Now I would like to share them with the Win 7RC computer. That is where the problem starts, no matter what I do this will not happen. I have them set up to share on the XP comp. I have tried many many things like using Vista drivers, connecting them direct to the Win 7RC comp, etc. Nothing works. When I have them connected to the Win 7Rc comp they install and say they are ready to use but they don't work. They show up when you click on Devices and Printers, but when you click on something to print, nothing happens.

The printers are a Epson R380, and a HP 7660. The reason I am thinking this is a more serious problem is I think this will be a problem whether I am using a Beta or a bonified version.

Thanx...Gunny...Any more info needed just let me know. Or if you think I should start a new post with this.

My System SpecsSystem Spec
.

12 Jul 2009   #2

Win 8 Release candidate 8400
 
 
printer drivers

Quote   Quote: Originally Posted by Gunny3053 View Post
I have two printers, both about 3/4 years old. They both work great, and I use them a lot. And as I said I have 2 computers, my XP computer and my Win 7RC computer. I am using KVM switch, connecting the 2. They are connected to the XP computer with USB. Now I would like to share them with the Win 7RC computer. That is where the problem starts, no matter what I do this will not happen. I have them set up to share on the XP comp. I have tried many many things like using Vista drivers, connecting them direct to the Win 7RC comp, etc. Nothing works. When I have them connected to the Win 7Rc comp they install and say they are ready to use but they don't work. They show up when you click on Devices and Printers, but when you click on something to print, nothing happens.

The printers are a Epson R380, and a HP 7660. The reason I am thinking this is a more serious problem is I think this will be a problem whether I am using a Beta or a bonified version.

Thanx...Gunny...Any more info needed just let me know. Or if you think I should start a new post with this.
thanks for pointing me here gunny
I assume you have gone into the printer cpanel and shared it, and installed the driver for both printer on both machines right?
cause Im doing the same setup. computers, kvm switch printers on 1 box shared with the others. My printer is a 3-4 year old epson as well. See the additional driver box on the uploaded image

Ken
My System SpecsSystem Spec
12 Jul 2009   #3

win7
 
 

Zigzag

I am fairly new to this networking, as you can tell. Now I should be able to see the other computer, the XP computer. But I don't. This I think is part of my problem. How is it going to share the printer if it cant see the other computer.

Yes I have done the share thing on the XP computer. I hooked up the printer to the Win 7RC computer directly, so it got the drivers for it and it said it is ready to use, then I took the USB cord and reconnected it to the XP computer.

Gunny
My System SpecsSystem Spec
.


12 Jul 2009   #4

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Gunny3053 View Post
Zigzag

I am fairly new to this networking, as you can tell. Now I should be able to see the other computer, the XP computer. But I don't. This I think is part of my problem. How is it going to share the printer if it cant see the other computer.

Gunny
from which computer (the win 7) do you not see the printers (xp?)
ken
My System SpecsSystem Spec
12 Jul 2009   #5

win7
 
 

zigzag.....Both USB cords from the printers are plugged into the XP computer, and I am trying to get them to work on the Win 7RC computer. I want to be able to use at least one of the printers on both computers, preferably the Epson R380.

Gunny
My System SpecsSystem Spec
12 Jul 2009   #6

Windows 7 RC Build7100
 
 

This issue seems to be caused by NT Lan Manager authentication level.
open Local Security Policy under Administrative Tools.
Navigate down the tree: Security Settings | Local Policies | Security Options
Find: Network Security:LAN Manager authentication level
Set To: Send LM & NTLM - use NTLMv2 session security if negotiated

I had a simular issue with mapping a network drive from an XP computer i use as a server (easier setup), and this resolved my issue.


(If this solved your issue give me REP)
My System SpecsSystem Spec
12 Jul 2009   #7

win7
 
 

Aheaton-- I did as you said in your instructions, still no work. Do I need to do a restart also.?

Gunny
My System SpecsSystem Spec
12 Jul 2009   #8

Windows 7 RC Build7100
 
 

Gunny,

How are you sharing the printer with the PC? I Understand that you have the usb cord and are sharing with a network share? In XP you can share the printer on XP computer # 1 with Windows 7 Computer # 2 using a "UNC Path". If the share path is \\xpcomputer1\printer-USB try typing that into the path to see if you can map the printer that way. Alot of times at work the darn printer does not show on the list. just check the computer name and sharename to make this work. see the screenshot below for additional resources.

http://aheaton.com/printerinfo.png
My System SpecsSystem Spec
12 Jul 2009   #9

Windows 7 RC Build7100
 
 
Hmm..

Quote   Quote: Originally Posted by Gunny3053 View Post
Aheaton-- I did as you said in your instructions, still no work. Do I need to do a restart also.?

Gunny

I do not see a reason for a restart on this, perhaps it is being a stubborn printer and is not reporting to the list directory. All hope is not lost though! Please refer to my above post and see if this helps.
My System SpecsSystem Spec
12 Jul 2009   #10

win7
 
 

Aheaton--We might be getting some where I did as you said, and a little box came up saying windows cannot do this ck that it is turned on and the address is correct. Is there some thing on the XP end that I should be setting too. I know that ports have to be shared.

Thanx Gunny
My System SpecsSystem Spec
Reply

 Printer Problem




Thread Tools



Similar help and support threads for2: Printer Problem
Thread Forum
Printer problem. Hardware & Devices
Solved printer problem Hardware & Devices
hp printer's problem Drivers
Printer Problem Hardware & Devices
Printer Problem - or Spooler Problem General Discussion
HP Printer Problem Hardware & Devices
Printer problem help please Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:05 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33