Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Hard drive problem? Maybe a bad HDD Controller?

13 May 2011   #1

Windows 7 Pro x64 SP1
Hard drive problem? Maybe a bad HDD Controller?

Hiya all!

I have a few problems on my head, and they start with a 2x WD HDD and ends with a 2x Seagate HDD.


Anyhow. here is my problem

The WDD are the green version, the one that changes speeds between 54 and 72 RPM, right, and my seagates are the Black Version 72 solid.

My problem is, the other day, BOTH of my seagates Black started slowing down, click sound, freezing, attempting to speed up the speed and return to normal operation, as for the Green WD's, well, nothing's wrong! (I will attach a wav file for you to listen to the sound)

This is the second pair of Seagate blacks that I am changing and I don't know what to do to make my HDD's work at optimal.

The 4 HDD's are hooked up with the same cable
ex: the power cable that runs out of the PSU is connected to the 2 WD HDD's AND the 2x seagates as well.
Maybe the problem is with the voltages? cause in that case, it should be the WD Green's that should parish, not the Seagate blacks...

Help me out please...

Running on:
Gigabyte GA-890GPA-UD3H
stock SATA Cables.
PSU 700W Coolermaster RS-700-PCAA-E3

My System SpecsSystem Spec
13 May 2011   #2

Windows 10 Pro. EFI boot partition, full EFI boot

Can you disconnect the WD drives from power and see if that improves the situation. The heads can park if the power is flaky, causing clicking from the parking.

Have you tested the drives with seagate's seatools program. If not, go to their website and download and run it.

Seagate 7200.11 drives have been problematic. Maybe they are OK now though they do have a history.
My System SpecsSystem Spec

 Hard drive problem? Maybe a bad HDD Controller?

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Windows has detected a hard disk problem. Hard drive failing?
Hey there guys, about six months ago I started receiving an error every few days on my computer on boot, and it was something along the lines of: 'pxe-rom: Check cable connection!'. To fix it I just used my Windows 7 install CD and it was fine, until whenever it'd happen again. Now, just about...
Hardware & Devices
hard drive problem
i installed a second hard drive into my pc i deleted all the files from it . but when i look at my computer there is a blue line and 18gb is used. i have tried to format the drive but cannot.i get a message saying windows cannot format drive quit any disk utilities or other programs that are...
Hardware & Devices
External hard drive controller going bad
This morning I had an error in my Event Viewer/system log. "The driver detected a controller error on \Device\Harddisk5\DR5." My questions: is the controller on the disk or a part of Win 7? How do I repair/replace the controller? I had the same message about another disk 2 days ago and...
Hardware & Devices
hard drive problem. Zero-ing out?
I've recently been having quite a bit of trouble installing windows 7 on a fresh hard drive. I wanted to do a clean win7 install so I deleted all my partitions and began installing on the single unalocated (sp) space. I went away and came back and noticed it in chkdsk and this went on for hours. I...
Hardware & Devices
Hard drive problem with partition. Even after a new replacement drive.
After sending in my new 750 GB Western Digital Black Edition hard drive due to my partitions getting completely screwed multiple times. I received a brand new replacement 1 TB Western Digital Black Edition hard drive yesterday. Everything was working fine until I turned on my desktop on today and...
Hardware & Devices
Problem with usb hard drive
I have a backup drive a wd 5000aavs and my laptop stopped recognizing it today after i formatted the drive with acronis disk director. This also happened with my 16gb san disk flash drive about a month ago. I have uninstalled all drivers for it and let if reinstall still not coming up with the...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:45.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App