Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Thrashing external HDD after delay??

19 May 2011   #1

Windows 7 64-bit
Thrashing external HDD after delay??

Hi all...

I'm running Win7 64-bit on a new Asus laptop. I have multiple external USB 2.0 HDDs connected to this laptop via a powered USB hub, one a 2TB Fantom Greendrive and a second a 1TB archive drive. The 2TB drive is my multimedia drive, and contains most of my MP3 files, graphics files and other non-application and backup stuff. I use the 1TB drive as a secondary backup. Both are left connected to the hub at all times. This PC is hooked to a keyboard/monitor which is shared with a second computer (a Macbook) via a KVM switch.

What's happening is that after about 28 minutes of inactivity, the Fantom HDD begins to rapidly click as something begins thrashing the drive. This usually happens while I'm working on the Macbook, so the Asus is receiving no input form my keyboard/mouse (the KVM switch has switched to the Macbook). If I click back to the Asus laptop via KVM switch, the clicking immediately stops.

I've checked the system monitor and I don't see any corresponding spikes in memory usage for the time immediately preceding the switch back to the Asus laptop via the KVM switch, nor has any of my multiple antivirus or malware scans (AVG, Avira and MalwareByte's Anti-Malware) detected any infection. I also checked to make sure that the thrashing is not the result of any automated antivirus scans (all are set to on-demand scanning) or automated backups (disabled - I back all files up manually).

Last, thinking this might be caused by something lurking in my screensaver, I disabled all screensavers and the behavior continued. It seems to happen a few minutes after the when the "Turn Off Display" from power management is invoked - I have power management set to turn off my display at 20 minutes and the thrashing seems to begin about 8 minutes after that (??). This seems like something that would be the hallmark of malware ("start activities only when the monitor is switched off so the user can't see what's happening"), but all my scans come up clean.

Any ideas?? I'm not so much worried that some piece of malware is scanning me (although I still think that's possible), as I don't hear the main C: drive being thrashed, nor is the other 1TB drive being thrashed - I'm more concerned about the drive getting trashed/worn out over time due to all the activity.


My System SpecsSystem Spec
20 May 2011   #2

Windows 7 64-bit

My System SpecsSystem Spec

 Thrashing external HDD after delay??

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
How to delay mount of external hard drive at startup
I have a Win7/Pro (32bit) PC with two external USB HDs. When I boot, the #2 HD is not recognized and does not power on (light out). But when I then unplug and replug it, it powers on and is recognized instantly. The HD then works normally. I have a total of 8 devices on the same USB hub and I...
Hardware & Devices
MSE thrashing disks after boot.
Ive noticed that MSE seems to do a hidden scan after you boot up and get to the desktop. Doesnt always do it but sometimes. Is there a way to prevent it from doing this? There is no option in the MSE interface and I cant see any option in task scheduler.
System Security
Hard drive thrashing upon shutdown
Hello, I've searched for a solution to my problem but have not found any. I'm having thrashing upon shutdown of my windows 7 box and can't figure out why. I have tried the obvious such as updating the bios, updating the sata bios, updating all drivers, disabling the floppy and testing the hard...
BSOD Help and Support
Win 7 - Core i7 but HD thrashing?
Hi All, Weird situation and wondered what advice people might have. I recently upgraded this whole system to one that should scream - Core i7 920, 6 GB triple channel RAM, Nvidia GTS 250 and Gigabyte UD-3R m'board. Anyway, it was running great but now, if I do ANY sort of large copy or use a...
Performance & Maintenance
slow and thrashing
After doing a clean install of Windows 7 Home Premium, my desktop became very slow and noisy. The hard drive seemed to be always thrashing, and windows explorer lagged. After reading the many similar posts, and trying all the fixes, what finally worked for me was uninstalling AVG 9 Free. I am...
Performance & Maintenance
Mouse delay and OpenGL games delay. Help!
Hi there. Im running Windows 7 Professional x86 final on this machine: athlon x2 5.000+ 2x2gb ddr800 dual-channel memory ati radeon hd 4650 512mb 128bits 500g sata hd The os is updated and all the settings of the os are on default. The settings of videocard are in performance/balanced.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:17.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App