Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: hangs after POST

24 May 2011   #1

Windows 7 Ultimate x86
hangs after POST

I have gone through a lot of googling before posting this one...
I have acer 8930G laptop, Intel ICH9M-E/M controller and Hitachi 2tb esata drive..
hdd is working fine but esata has problems (No h/w problem i have CHECKED)

When my drive is connected and I do a bootup.. it hangs after POST and again on Windows 7 boot logo, when i remove the esata drive it boots normally... if i connect it after windows logon, it again hangs..

I played around a lot with various drivers (Standard AHCI from Microsoft, various versions of Intel ICH9M-E/M controller to The results are as follows :
Standard AHCI : doesnt detect the esata drive : detects the drive but it hangs as stated above : doesnt detect the drive and Intel Matrix rapid storage technologies crashes..

Some other things which I have tried are :

played with the power options a bit regarding hard disk sleep and all, still no luck

playing around with BIOS updated it.

P.S.: SATA mode is AHCI

Sometimes with luck using
Often the esata hdd is detected out of the box and runs quite flawlessly (awesome transfer speed ) but It doesn't do it every time..

So it is not h/d problem, neither BIOS ... still trying to figure out whats the problem

My System SpecsSystem Spec
24 May 2011   #2

Windows 7 Ultimate x86

some help with my problem ??
My System SpecsSystem Spec
24 May 2011   #3

Windows 7 Ultimate x64

Have you spoken to acer technical support about the problem?
My System SpecsSystem Spec

24 May 2011   #4

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint

The only time I have had a similar problem was when I had a defective hard drive. I might suggest you run a diagnostic program to make sure the HDD is not causing the problem.
My System SpecsSystem Spec

 hangs after POST

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
sometime POST cannot complete, sometime hangs after boot
I have a laptop hcl notebook "hcl notebook p28 pdc". It has boot problems, sometime it cannot start POST. I use usb POSTCARD to diagnose, power to the POSTCARD come and go and the code was always FF. sometime it can complete POST and windows boot but use to hang after some minutes with slight...
Hardware & Devices
PC hangs on post screen after doing Windows 7 restart
I just built my computer today, everything is working fine and all drivers are installed from official websites etc. When I start my computer from complete off (cold startup) the BIOS splash screen lasts for 1 second before Windows 7 starts booting, and the computer startup speeds are fine....
Hardware & Devices
System hangs at post
Today while I'm trying to boot my computer, it just hangs at post screen and last forever Here's what my system reads when it hangs I have little computer knowledge and don't even know where the problem is Please help me Thank you
BSOD Help and Support
Bootup hangs on post screen.
System: - Once You Know, You Newegg All computer parts are brand new, including the case. Bios are essentially default (no overclocking at least). Here's a brief story of what I've gone through so far: I installed Windows 7 last night, installed the necessary updates, MoBo...
Performance & Maintenance
FireFOX 3.5.5 hangs also IE8 hangs
i really didnt know where to put this software debugging or what.. So i put it here ima sorry guys if this is the wrong spot. On my AMD turion II m500 laptop my IE8 and Firefox both hang constantly Same ie8 build and firefox build as well as win7 build on my desktop and laptop. But my desktop is...
Browsers & Mail
WMP 12 Hangs
In Windows 7 Beta, RC, and now the official version, Windows Media Player 12 hangs under the following circumstances and will not work until I reboot: When I open WMP to my library and click the Play button. When I pause a song for several minutes then try to unpause it. Sometimes, even...
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:37.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App