Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 x64 doesn't boot if a NAS linux drive is plugged


02 Jun 2011   #1

Windows 7 Enterprise x64 (90 days evaluation dwnld from MS website)
 
 
Windows 7 x64 doesn't boot if a NAS linux drive is plugged

Hi to all of the forum users

I've a bad issue I can't find references on the forum.

I have downloaded last friday the windows 7 enterprise 64 bit from microsoft website (evaluation 90 days), I've fully updated it including SP1.

Everything runs fine.
Please note that what you read next, on the this same pc, I tried to do installing windows xp pro SP3 fully updated and what described below, doesn't happen, windows xp boots fine and the drives show fine, either 4 drives at once coming from a raid 5 NAS set: I would say this is not an hardware problem.
Today I've plugged to my windows 7 pc one healthy drive coming from one NAS device, this because I must do some tests on it (please note that I have several NASses with different drives and drive brands and this issue repeats with all of them, tested all).

You know, those drives are partitioned by some kind of linux file system.

The issue is that windows 7 boot hangs with any NAS drive plugged.

When I turn on the pc, after the BIOS post, it does appear one "Loading Files" progress bar that repeats some progresses, finally the screen empties and you can see only one cursor blinking on top left corner.

At this point windows 7 boot hangs.

I Ctrl-Alt-Del and at the next boot I get the screen that prompts for
"Launch Startup Repair"
"Start Windows Normally"
this also mean that BIOS drives boot order is correct. Any of the two options doesn't work.

I did the counter proof, so I tested twelve different NAS drives and the result is still the same.

The mainboard is a P8P67 Deluxe from asus with 8 onboard SATA ports, 2 are from a separated chipset (asus call them the blue ports): the issue happen on all of the ports, either on the Blue Ports that are intended for storage only.

Looks like that windows 7 tries to "mount" something from these drives (maybe the partitions? Something from the boot sectors?) and fails.

Do you have any idea/suggestion/tip about this?

I would like to switch to windows seven 64 bits, but if I can't work on this kind of drives... I must forget about windows 7 and switch back to XP.

Thank you for any suggestion either a work around to be able to boot windows and being able to work on those kind of drives.

As Next and last test I'll prepare a standard linux installation on another pc and I'll try to plug that pure linux drive and see what happen; I'm still thinking about those drives boot sectors' microcode.

Kind regards and thank you for any tip
Cor




Attached Thumbnails
Windows 7 x64 doesn't boot if a NAS linux drive is plugged-boot-nas-drive.jpg   Windows 7 x64 doesn't boot if a NAS linux drive is plugged-boot-nas-drive-after-reboot.jpg  
My System SpecsSystem Spec
.

Reply

 Windows 7 x64 doesn't boot if a NAS linux drive is plugged




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:18 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33