Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: is hard disk broken or controller

05 Jun 2011   #1

windows 7 pro
 
 
is hard disk broken or controller

i have asus motherboard,chipset mcp 430,i have two hard drives,sata (wd 6400 aaks) and ide disk wd 800bb 80 gb.my primary master is sata disk,secundary is dvd cd rw,and i used to have my ide wd 80 gb on cable select and it worked fine....now i can see my drive in windows 7 x64,but booting taks 10 min approximatly..windows shows ide disk is its in pio mode 4. ,something is wrong when post message takes to long to finnish)When i try to install Windows 7 on wd8800bb and format drive to install win 7 on it computer says there is no controller for drive in question set in bios,and it wont format drive and install win 7.....is there a simple way to exclude hard disk failure(boot post always says is udma 5,smart status ok,so i dont believe its broken)....this problem i to0 hard for me,but i hope it could be resolved,in any way. how to check if its broken.i dont have no one to test hard drive,like frends pc,.is it some sort of my motherboard problem..the ribbon cable is new 80 pin bought in store .

My System SpecsSystem Spec
.

05 Jun 2011   #2
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Hello, check that the chipset drivers are all current. Try moving your IDE jumper to Master position.
Please post a snip of your disk management window expanded.

You can download the FREE HD TUNE and give it a run. It is the second one down the page.
My System SpecsSystem Spec
05 Jun 2011   #3

windows 7 pro
 
 

no chipset drivers for nvidia nforce 430 mcp..for win 7.....and no again,i have the same problem.it boots 10! min.,...it takes 2-3 min standing on post message and hardly goes trough!.when it was working it only worked in cs jumper....now i neeed to determine hard disk status,or controller status...that the point..to find out what went wrong!thx i will post a snip
My System SpecsSystem Spec
.


05 Jun 2011   #4
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Western Digital support. Use you model number and download their diagnostic tool.
did the long boot time only start after you put in the IDE drive?
My System SpecsSystem Spec
05 Jun 2011   #5

windows 7 pro
 
 

Quote   Quote: Originally Posted by Britton30 View Post
Western Digital support. Use you model number and download their diagnostic tool.
did the long boot time only start after you put in the IDE drive?
Yes! only after install disk drive!
My System SpecsSystem Spec
05 Jun 2011   #6

windows 7 pro
 
 

Code:
http://imageshack.us/photo/my-images/24/snipl.jpg/

Code:
http://imageshack.us/photo/my-images/833/pio4mod.jpg/
My System SpecsSystem Spec
05 Jun 2011   #7

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

I have found that every time that I connect or disconnect a drive, that I have to go back into the BIOS and reset everything. Also, your comment about it not find a controller for the drive, makes me wonder if you have it set for SATA or PATA?
My System SpecsSystem Spec
05 Jun 2011   #8

windows 7 pro
 
 

Quote   Quote: Originally Posted by seekermeister View Post
I have found that every time that I connect or disconnect a drive, that I have to go back into the BIOS and reset everything. Also, your comment about it not find a controller for the drive, makes me wonder if you have it set for SATA or PATA?
i know that there are 2 controllers ,one for sata and one for ide..i dont have achi ,so in post bios all disk are listed as IDE(first is listed as ide sata hard drive,second is cd/dvd and third is WD 80 Gb ,and all setup as master).... under bios menu its all ok,it shows ,wd 8800bb as ide disk,with onboard ide conroller,sata disk is shown as sata device, and dvd/cd rom is also recognized as sata )so i have one ide disk,and have 2 sata devices .
My System SpecsSystem Spec
05 Jun 2011   #9
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Follow the link in my first post to upload a screenshot. I can't see the imageshack, it's too small even after enlarging.
My System SpecsSystem Spec
05 Jun 2011   #10
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Quote   Quote: Originally Posted by neverall View Post
Quote   Quote: Originally Posted by seekermeister View Post
I have found that every time that I connect or disconnect a drive, that I have to go back into the BIOS and reset everything. Also, your comment about it not find a controller for the drive, makes me wonder if you have it set for SATA or PATA?
i know that there are 2 controllers ,one for sata and one for ide..i dont have achi ,so in post bios all disk are listed as IDE(first is sata hard drive,second is cd/dvd and third is WD 80 Gb ,and all as master).... under bios menu its all ok,it shows ,wd 8800bb as ide disk,with onboard ide conroller,sata disk is shown as sata device, and dvd/cd rom is also recognized as sata )i have 2 sata connection used for disk wd6400 aaks, and cd/dvd)thats all i know!
Does this mean SATA or PATA?
My System SpecsSystem Spec
Reply

 is hard disk broken or controller




Thread Tools



Similar help and support threads for2: is hard disk broken or controller
Thread Forum
Confused about installing Windows on my hard disk,hard disk problem Installation & Setup
can't install to disk, turn on disk controller in BIOS General Discussion
Not sure if hard drive is broken Hardware & Devices
If my hard drive is broken. Hardware & Devices
Correct SATA Drivers for hard disk controller? Drivers
Is my hard drive broken ? Hardware & Devices
My hard disk broken! Be wary of WinMedia player 12.0 BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:12 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33