Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Printer Services Haywire & "Add Printer" Broken


06 Jun 2011   #1
flowingfire

Windows 7 Ultimate
 
 
Printer Services Haywire & "Add Printer" Broken

Hi. I'm running Windows 7 Ultimate 64-bit. Suddenly, my printer no longer receives recognition from the computer. It worked just fine for over 6 months, and simply won't be recognized any longer. Re-installing drivers doesn't help. Any ideas?

I have attached some pictures for reference. It seems the computer recognizes the hardware is there, and that it is an HP Laserjet 1018 installed. The services that normally run in the background responsible for printing seem to be haywire, though.

One dialogue says that the "print spooler service" is not running. Huh? Another said, "The Active Directory Domain Services is currently unavailable."




Attached Thumbnails
-1.jpg   -2.jpg   -3.jpg  
My System SpecsSystem Spec
.

06 Jun 2011   #2
pricetech

Windows 7 Professional 64 bit
 
 

Have you tried completely removing the printer software ?? HP used to have a utility for some of its printers that went beyond a normal uninstall and removed all traces of the printer. You might look for that. Once removed, install the latest from HP again, making sure to follow any specifics about when the printer should be plugged in.

Have you restarted the spooler or the computer as prompted ??

If you're not part of an Active Directory domain, the service shouldn't be running.
My System SpecsSystem Spec
06 Jun 2011   #3
flowingfire

Windows 7 Ultimate
 
 

I have run services.msc and restarted the print spooling service repeatedly. It just crashes again soon after.

I have re-installed the HP printer driver numerous times. It's not a driver issue, I'm pretty sure... It's a print services issue and it just doesn't work. I have also uninstalled a bunch of other software to see if it was conflicting... Still hasn't helped.

Yes, I have changed settings and restarted the computer over a dozen times now.

Still, no idea what to do.
My System SpecsSystem Spec
.

Reply

 Printer Services Haywire & "Add Printer" Broken




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:41 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App