Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Hmmm... WHidInst.exe didn't work for me.

13 Jul 2011   #1
Michael F

Windows 7 64 bit
 
 
Hmmm... WHidInst.exe didn't work for me.

I've had a WD 500G WD5000D032 MyBook Premium for many years and after upgrading to 64-bit Windows 7 Ultimate, I've had the "WD&External_HDD_Button_&_Lights" error in Device Manager since day one and have never been able to correct the problem.

My system drive is all but kaput so I backed up all of my important files and ordered a Crucial 128 GB m4 SATA 6Gb/s SSD with a 2.5" to 3.5" drive converter as a replacement. Why am I telling you this, honestly, I have no eff'in idea! Anyway, I'd rather futz around now just in case something I do causes a problem ; then the failing drive will be affected and not the SSD and I can install the 500G WD5000 MyBook Premium in an error-free fashion to the new system drive.

Does anybody have a solution because I don't want to replace a drive that works perfectly fine, except that it runs 24/7 and turns on all by itself after I turn it off. I also don't know if having the yellow warning triangle with an exclamation point in Device Manager will affect the performance of my PC, especially since Win7 doesn't recognize my Nikon digital camera either...

Thanks in advance!!!!


My System SpecsSystem Spec
.
15 Jul 2011   #2
pooch

Windows 7 Ultimate x64
 
 

Hello Michael, welcome to the forum

It would help if you were to fill out your system specs

Name:  Capture.JPG
Views: 3
Size:  13.5 KB
You could try going through this; USB Driver - General Fix for Problems[2]=Hardware%20and%20Drivers

and it would help if you post the error messages, using the snipping tool and the paperclip to upload snips so that we can see them.

Name:  Capture1.JPG
Views: 120
Size:  10.7 KB


My System SpecsSystem Spec
16 Jul 2011   #3
Michael F

Windows 7 64 bit
 
 

Thanks Pooch. I got my answers from WD and Nikon. Neither unit is compatible with Windows 7 so I'll just have to live with the errors.

As for my system specs, I'll fill out what I know, but Dell shrouds their builds in mystery which is why I'll be building a new system very soon.
My System SpecsSystem Spec
.

16 Jul 2011   #4
pooch

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Michael F View Post
Thanks Pooch. I got my answers from WD and Nikon. Neither unit is compatible with Windows 7 so I'll just have to live with the errors.
Sorry to hear this
Quote   Quote: Originally Posted by Michael F View Post
As for my system specs, I'll fill out what I know, but Dell shrouds their builds in mystery which is why I'll be building a new system very soon.
You know where to come if you need any help
My System SpecsSystem Spec
Reply

 Hmmm... WHidInst.exe didn't work for me.




Thread Tools




Similar help and support threads
Thread Forum
What to get to play BDs on PC: VLC doesn't work, PowerDVD didn't help
Since I bought my BD player (external), I got Cyberlink PowerDVD 10 with it (didn't buy it, so it was probably suggested) and that stayed with me until I noticed later on that it wouldn't play and said it didn't work after I paused a movie for more than 10 minutes. Then an update came, and it...
Music, Pictures & Video
Video Card didn't work
I took out a video card and put a better one in and the system slow down by 10 folds and froze so I had to put the other video card back in. I think my mistake was I should of went to the Device Manager and deleted the driver for the display adapter then turn off the computer installed the new...
Graphic Cards
Theme install didn't work black
Hey what's up all. So anyway I read the sticky above. I downloaded the 64 bit program and did the 3 patches and restarted. Then I dragged my zipped theme (Dynamic black) into c:/windows/resources/themes but when I went to personalize it doesn't show up as an installed theme... what's wrong?
Themes and Styles
" New Folder '' Didn't work
Hey I have a small problem and need help & sorry If it isn't in the right section. '' New Folder '' Didn't work for me anymore If i press '' New Folder '' or Right click it didn't appears , I am using w7 ultimate X64 (6.1.7600) http://i49.tinypic.com/2s85v8l.jpg ...
General Discussion
The games didn't work !!!
Hi everybody ! I have a problem with my graphich card.. When I wanna' enter in a game this appeares for me : Should I update my driver :) ????
Graphic Cards
Not sleeping (general solutions didn't work)
Hello; When I press Sleep at start menu, screen just goes to black for 1-2 seconds and after Windows Logon menu appears. I've tried Allow waker timers to off, When sharing media to Allow the computer to sleep, Allow hybrid sleep to On/Off, USB selective suspend settings to Enabled/Disabled. ...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:08.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App