Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB 3.0 ports refuse to work as USB 3.0 ports


09 Aug 2011   #1

Windows 7 Ultimate x64
 
 
USB 3.0 ports refuse to work as USB 3.0 ports

A few days ago I installed a USB 3.0 card (to be precise, this one: 2-Port USB 3.0 SuperSpeed PCI-E Controller Card - Free Shipping - DealExtreme). It uses the very common NEC PD720200 USB 3.0 controller. I installed the required drivers for Windows 7, and the card worked fine for the first day or so. but not since. Whenever I plug in a USB 3.0 external hard drive, I get a false "This device can perform faster..." message, as if I had plugged the drive in a USB 2.0 port.

The external drive I am using is a Western Digital MyBook Essential 1130. It is definitely a USB 3.0 drive, and came with the required USB 3.0 cable. While the USB 3.0 card was working, I got full-speed transfers to the limit of the hard drive's ability, about 90-100 MB/s. Now I can only get USB 2.0 speeds (33-34 MB/s). Windows insists I have the drive plugged into a USB 2.0 port even though it is plugged directly into the USB 3.0 card.

Things I tried so far:
-rebooting and complete power cycle. No difference.
-plugging the drive into one port or the other. Also no difference.
-Looked in Device manager. No help there either. The controller is recognized as a USB 3.0 device is using the proper NEC drivers.

Other info that may be important:
-No overclocking settings in use.
-I made sure the cable was plugged in all the way. It's in as far as it can go, but the ports will still only act like USB 2.0 ports.

This is very frustrating. How do I fix it? I might as well throw the card away if it is only going to act as a USB 2.0 device.

My System SpecsSystem Spec
.

09 Aug 2011   #2

Windows 7 Enterprise x64 no SP
 
 

Go to device manager and go the props of those usb ports.
Click uninstall, now they will disappear.
Now install your drivers again, which came with the card
Reboot.
My System SpecsSystem Spec
09 Aug 2011   #3
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

If SG's steps don't work, try downloading your driver here, PD720200 | USB3.0 Host Controller | Product Lineup | USB | ASSP | Products | RENESAS Electronics Renesas has taken over NEC.
My System SpecsSystem Spec
.


09 Aug 2011   #4

Windows 7 Ultimate x64
 
 

Will give that a try when I reboot. I'm running Ubuntu 10.04 at the moment. For some reason, the ports won't work as USB 3.0 ports here either. The Linux kernel has supported USB 3.0 since late 2009 so go figure.

My Linux USB 3.0 problem may not be related to my Windows 7 USB 3.0 problem, but it does seem suspiciously coincidental.

Wish I had another computer with USB 3.0 ports to test with, but I don't.

update:
Nope, reinstalling the drivers did nothing. Windows still stupidly insists that I have the drive plugged in a USB 2.0 port, when it is clearly in a USB 3.0 port.

Did you try that link you posted? There actually isn't any way to download drivers from the Renesas website.

2nd update:
Also tried changing the card to a free PCI Express 2.0 16x slot. It still refuses to work as a USB 3.0 port, I only get USB 2.0 connections. The card must be a piece of junk.

3rd update:
Yep, it's junk. Installed the card in a different computer, installed the drivers, rebooted, still only works as a USB 2.0 card. Worthless.

I suppose there is a *remote* possibility that the USB 3.0 cable supplied with my Western Digital external HDD has gone bad, but I'd much sooner suspect a $13, no-name USB card than the cable. I have another USB 3.0 cable on the way anyhow because I needed a longer one. Will see whether that makes a difference.

4th (and last) update:

It was the lousy MyBook enclosure that was the problem. I swapped the 3 TB HDD to a Zalman HE-350-U3E enclosure and now all is well. It connects to my USB 3.0 ports at USB 3.0 speeds.
My System SpecsSystem Spec
27 Oct 2012   #5

MS Windows 7 Home Premium 64-bit SP1
 
 

Might as well post this, it might offer some help.

there is a process called iusb3mon.exe, which i think is related to the usb3 ports, maybe you stopped that process?
My System SpecsSystem Spec
Reply

 USB 3.0 ports refuse to work as USB 3.0 ports




Thread Tools



Similar help and support threads for2: USB 3.0 ports refuse to work as USB 3.0 ports
Thread Forum
Solved Front USB ports not working, but rear USB ports work Hardware & Devices
Solved USB 3 ports do not work Hardware & Devices
Is it possible ALL 6 USB ports to not work ? Hardware & Devices
Solved USB ports don't work Hardware & Devices
LIBusb, USB ports doesn't work. Safe mode also no work Drivers
monitor usb ports do not work Hardware & Devices
All ports of the USB does not work Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:51 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33